Re: roadnav question

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Thursday 21 February 2008, Amadeus W.M. wrote:
>On Thu, 21 Feb 2008 21:58:16 -0500, Gene Heskett wrote:
>> Greetings;
>> Tried to install the f7 version of roadnav-0.19 here, but it apparently
>> was compiled with too small a memory footprint as it goes away about 10
>> minutes after it locks up when you click on Download Tigerline maps.
>> So I thought I'd build the tarball and went after it and its library.
>> Figuring the library was first, I did the ./configure thing and it bails
>> out, no wxWidgits installed.  That might be ok except there ain't no
>> such beast. I did find a wxGTK on srcforge that is not available via
>> yumex, which I believe fixed these deps the last time, but if that's the
>> case, why did the roadnav rpm install without running into that set of
>> deps that should have stopped it dead?
>> So that's question 1.
>> Question 2 and 3 is what is it really telling me I need when it
>> complains about a missing wxWidgits?  For linux, is that wxGTK?  If so,
>> is there an F8 rpm?
>> Thanks.
>> --
>> Cheers, Gene
>> "There are four boxes to be used in defense of liberty:
>>  soap, ballot, jury, and ammo. Please use in that order."
>> -Ed Howdershelt (Author)
>> "Absolutely nothing should be concluded from these figures except that
>> no conclusion can be drawn from them." (By Joseph L. Brothers,
>> Linux/PowerPC Project)
>To compile you need header files, not just the actual libraries. The header
>files are found in the *-devel packages. So you would need both wxGTK and
>When you install and run a precompiled package you don't need the headers,
>only the libraries.
>However, in the case of roadnav I don't see that it requires wxGTK:
>[[email protected] ~]# rpm -qa | grep -i wx
>Then, one by one:
>[[email protected] ~]# rpm -q --whatrequires compat-wxGTK26
>no package requires compat-wxGTK26
>[[email protected] ~]# rpm -q --whatrequires wxPython
>[[email protected] ~]# rpm -q --whatrequires wxGTK
>[[email protected] ~]# rpm -q --whatrequires wxGTK-gl
>no package requires wxGTK-gl
>And in fact if I do
>rpm -q --requires roadnav
>again I don't see anything about wx.
>At any rate, I have it installed on F8 and it crashes when I try to set
>an address. It worked fine in F7.

I'm seeing segfaults in the syslog for the F7 version of 0.19.

Feb 21 21:05:49 coyote kernel: [799800.925900] roadnav[30556]: segfault at 
00000041 eip 494b9d2f esp bf9d8570 error 4

And it works fine on my lappy with F8 on it, but IIRC I had to build from 
scratch there too, starting with wxGTK, then libroadnav and finally roadnav.  
That's if my wet ram is still being refreshed, that was about the last week 
of Oct or the first week of November when I did that in a big hurry so I 
would have roadnav with me while I drove to Nebraska to say goodbye to a 
daughter dying of cancer, so those details could be a bit fuzzy.

Anyway, wxGTK is building from the tarball.  I inspected the Dec respin of 
F8's dvd, and none of that is on the dvd, nor can yumex find it to install 
it.  That really really ought to be part of the distro IMO.  Of course that 
opinion, and a buck and a half will get you a fresh tall cuppa at 7-11 these 
days. :-)

Thanks for the quick reply.

Damn this new compiler is slow, I'm tempted to call a surveyer & have him set 
stakes to see if its moving.  Almost 20 minutes so far just building wxGTK.  
Win a game of patience, its still going.  Win 2 out of 4 more.  Done, 
ldconfig, then config and build libroadnav, ldconfig, and making roadnav 
itself now.

And that upchucks all over itself, something still missing:

more undefined references to `wxStringBase::InitWith(wchar_t const*, unsigned 
int, unsigned int)' follow
collect2: ld returned 1 exit status
make[2]: *** [roadnav] Error 1
make[2]: Leaving directory `/usr/src/roadnav-0.19/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/roadnav-0.19'
make: *** [all] Error 2

And there were 20+ similarly worded warnings above that before it bailed out.

So what do I need to fix this?  That looks like Perl maybe?  Or c++, I don't 
grok either of those well enough to even fake it.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
  It's more than magnificent-it's mediocre. -Samuel Goldwyn

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux