Re: roadnav question

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 21 Feb 2008 21:58:16 -0500, Gene Heskett wrote:

> Greetings;
> 
> Tried to install the f7 version of roadnav-0.19 here, but it apparently
> was compiled with too small a memory footprint as it goes away about 10
> minutes after it locks up when you click on Download Tigerline maps.
> 
> So I thought I'd build the tarball and went after it and its library.
> Figuring the library was first, I did the ./configure thing and it bails
> out, no wxWidgits installed.  That might be ok except there ain't no
> such beast. I did find a wxGTK on srcforge that is not available via
> yumex, which I believe fixed these deps the last time, but if that's the
> case, why did the roadnav rpm install without running into that set of
> deps that should have stopped it dead?
> 
> So that's question 1.
> 
> Question 2 and 3 is what is it really telling me I need when it
> complains about a missing wxWidgits?  For linux, is that wxGTK?  If so,
> is there an F8 rpm?
> 
> Thanks.
> 
> --
> Cheers, Gene
> "There are four boxes to be used in defense of liberty:
>  soap, ballot, jury, and ammo. Please use in that order."
> -Ed Howdershelt (Author)
> "Absolutely nothing should be concluded from these figures except that
> no conclusion can be drawn from them." (By Joseph L. Brothers,
> Linux/PowerPC Project)


To compile you need header files, not just the actual libraries. The header 
files are found in the *-devel packages. So you would need both wxGTK and 
wxGTK-devel. 

When you install and run a precompiled package you don't need the headers, 
only the libraries.

However, in the case of roadnav I don't see that it requires wxGTK:


[[email protected] ~]# rpm -qa | grep -i wx
wxPython-2.8.4.0-2.fc8
wxGTK-2.8.4-6.fc8
compat-wxGTK26-2.6.4-0.8
wxGTK-gl-2.8.4-6.fc8

Then, one by one:

[[email protected] ~]# rpm -q --whatrequires compat-wxGTK26
no package requires compat-wxGTK26
[[email protected] ~]# rpm -q --whatrequires wxPython
tovid-0.31-3.fc8
[[email protected] ~]# rpm -q --whatrequires wxGTK
wxGTK-gl-2.8.4-6.fc8
[[email protected] ~]# rpm -q --whatrequires wxGTK-gl
no package requires wxGTK-gl

And in fact if I do 

rpm -q --requires roadnav

again I don't see anything about wx.


At any rate, I have it installed on F8 and it crashes when I try to set
an address. It worked fine in F7.




[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux