Re: [patch] Combine path_put and path_put_conditional

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Sep 28, Andreas Gruenbacher wrote:

> The name path_put_conditional (formerly, dput_path) is a little unclear.
> Replace (path_put_conditional + path_put) with path_walk_put_both,
> "put a pair of paths after a path_walk" (see the kerneldoc).

Hmm, I don't know. To put both the nd and path is at the moment only used in
some error paths. I have another series of patches pending which is using
path_put_conditional outside of error paths. So please don't remove
it. Besides that the naming completely hides that the conditional release of
the vfsmount reference. Besides that I would name it path_put_both() just to
make it more "beautiful" wrt the other path_put*() functions.

> @@ -996,8 +1006,8 @@ return_reval:
>  return_base:
>  		return 0;
>  out_dput:
> -		path_put_conditional(&next, nd);
> -		break;
> +		path_walk_put_both(&next, &nd->path);
> +		goto return_err;
>  	}
>  	path_put(&nd->path);
>  return_err:
> @@ -1777,11 +1787,15 @@ ok:
>  	return 0;
>  
>  exit_dput:
> -	path_put_conditional(&path, nd);
> +	path_walk_put_both(&path, &nd->path);
> +	goto exit_intent;
> +
>  exit:
> +	path_put(&nd->path);
> +
> +exit_intent:
>  	if (!IS_ERR(nd->intent.open.file))
>  		release_open_intent(nd);
> -	path_put(&nd->path);
>  	return error;
>  
>  do_link:

IMHO introducing another label just to use it here isn't worth the change.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux