Re: System lockup problem when adding more memory - FC5

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Gene Heskett wrote:
On Tuesday 03 April 2007, Cokey wrote:
I have an older dual processor server that has been happily running FC5
since it was released.  It currently has 4G of memory and has the
capacity for 8G using 1G sticks.   Recently I was given 2 1G sticks and
tried to upgrade the system.  The system recognizes the memory and
boots, but then locks up with:

exec of initj(/sbin/init) failed: Exec format error.

Removing the memory clears the problem.  I have also tried some 512
sticks and they also cause the same problem.  Essentially anything over
4G regardless of the how that's arrived at will cause the lockup.

Looking for any hints/ideas.

There is, in the kernel's .config file, an entry to switch it to handle more than 4GB of memory. I believe you'll have to set that option and rebuild/reinstall the kernel.

In fairly recent kernels, say the last year or so, that option line is:

# CONFIG_HIGHMEM64G is not set

Use a make (x/menu)config to turn that on.



I'm using the stock SMP kernel (2.6.19-1.2288) and it comes with the large memory model turned on (CONFIG_HIGHMEM64G=y). Thanks for the idea. Wish it were that easy.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux