Re: Partial FC6 upgrade? RPM database

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



At 5:07 PM -0500 11/18/06, Jim Cornette wrote:
>Tony Nelson wrote:
 ...
>> However, from reading RPM's source, the proper and undocumented command is:
>>
>>     []$ rpm --verifydb
>
>Thanks! I ran the command just now on my FC6 installation and this
>command came back with no output. At least I verified both databases
>with the email read and trials.
>
>>
>> which seems to work fine as a normal user, as it opens the files read-only.
>
>Since some files are not visible to normal users, I usually do verify
>operations as root. I also tried the command as a normal user and
>nothing was flagged. For rpm -qaV though, I found chroot files and
>intentionally hidden from the normal user to be flagged as missing if
>done as a normal user.

I did a "rpm -vv --verifydb", which is why I have some confidence that the
command works as a normal user.  No new corruption yet, though, to prove
it.  Rpm, of course, can access the RPM database.  It's not the same issue
as accessing every file on the system, which rpm cannot do as a normal user.
-- 
____________________________________________________________________
TonyN.:'    The Great Writ     <mailto:[email protected]>
      '      is no more.             <http://www.georgeanelson.com/>


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux