RE: Yum update seems to have stalled

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Herschel wrote:
| Claude Jones wrote:
|| I'm doing a reinstall and am now going through the update
|| process. It found a huge number of upgrades and was moving
|| through them, but now, on 933/969 it's been stalled for half
|| an hour on 'completing update for gimp'. Is this normal? If
|| not, what happens if I abort? If I choose to abort, is there a
|| preferred way? 
| I am unsure this will be of any help, but I just installed FC 3
| (probably a very early version off a Linux Format DVD - Jan
| issue) on a laptop this weekend.  All efforts failed using the
| connection via the built in updater.  Yum update (command line)
| was suggested and it had only need for 369 updates and I mostly
| left it alone while it churned away checking aperiodicly.  Near
| the end I found I found it failed on Natulus, I did a Ctl-C
| expecting the worse and just tried to rerun: "yum update" only
| to be told I was completely updated. 
| Note the difference, however, I had an explicit message
| informing me of a premature halt so our situations differ.
| It might be possible that an abort may leave you with most of
| the updates completed, if it is still locked up you could try
| this "method".  Warning until yesterday I have only read about
| yum having never used it previosly - I was impressed.

Well, I ran out and ran errands while I waited to see if anyone
had some cogent advice to offer. When I returned the machine was
still stalled. Ctl-C didn't do anything, so I finally cold
rebooted into level 3. When I tried a yum update again, it said
there was a missing dependency 'boost' needed for 'boost-devel'
and quit. I'd run yum with the fedorafaq yum.conf file that first
time. I just ran it again in level 5 with the redhat network
utility which uses different repos, and it installed 4 additional
packages and said it was completely up to date. It's funny, this
has happenned before - I try one set of repos, and there's a
problem, and then I use the utility built into FC and it gets me
past the logjam. There was a thread recently about removing
up2date and I thought to myself that this kind of thing is a good
reason to keep it. Now I have an example.   

Claude Jones
Levit & James, Inc./WTVS
Leesburg, VA, USA

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux