Re: Upgrading from FC8 to F12 - please help

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello All,

Wednesday, November 25, 2009, 11:14:34 PM:

> Hello Craig,

> Wednesday, November 25, 2009, 10:35:04 PM, you wrote:

>> As I understand it, a Promise FastTrak RAID is what is known as 'fake
>> raid' and not supported by out of the box installation unless you
>> provide a 'driver module' at boot time. I suspect that this is something
>> you did to get F8 installed originally.

> Yes, it's probably a 'fake raid'. But I didn't need any additional
> drivers to install Fedora 8 several years ago - I remember that for
> sure.


>> The real Linux recommendation is to disable the 'fake raid' aspects of
>> the FastTrak controller and just use the drives as normal SATA drives
>> and create software RAID upon installation. It will be faster, more
>> reliable and not create any portability issues later on.

>> Then the other problem you have is that anaconda, as you have discovered
>> does not support installation to a degraded RAID setup. It's not
>> impossible to do, you just have to work around it. The idea would be to
>> setup the degraded array manually and then choose the existing
>> partitions for you installation within anaconda manually and don't let
>> anaconda create the RAID partitions at all...just use what is existing.

> In this case anaconda doesn't see anything! No physical devices at
> all! I tried deleting existing partitions and running installer again
> - same story, anaconda acts as there are no drives installed.

> Thinking of a bad/missing driver again, but I'm pretty sure it
> worked 'as is' in Fedora 8.


>> I think you are making this way too difficult on yourself. I would give
>> up completely on 'upgrade' from F8 to F12. I would give up using Promise
>> FastTrak 'fake' RAID, back up all of your files from your 'fake raid'
>> installation and then use anaconda to do a clean install and set up the
>> software raid for you and then you still have your files backed up on
>> another drive.

> Yep! Doing it now. Killed the RAID on my FastTrak board, anaconda saw
> the disk and is now installing. Not sure if I will want to make it a
> RAID again, as I don't see any benefits now...

> Perhaps, getting a 'real' RAID adapter could make things better. I
> suppose a real RAID1 would be visible as one device only, so anaconda
> (or whatever software it will be) won't know if it's degraded or not
> and will just work until last drive fails - that's what I expect from
> RAID1, generally.
> Unfortunately I don't have a real raid card to test it now. Will have
> to check it some other time.


> P.S. Still really worried about my data drives. They're now
> disconnected, waiting for install process to finish. It will be very,
> very bad if they got corrupted during my attempt of 'preupgrade'...


I finally finished with reinstallation and basic configuration of my
new F12 system. No RAID this time, at least not yet...

It appeared that my data drives were not modified by the preupgrade
process (or whatever it was that caused my system partition to go mad),
so I didn't loose any critical data.

Thanks a lot for all your help! I couldn't make it without you!


-- 
Best regards,
 Andrew

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux