Problem in reboot for preupgrade F9 -> F10

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi all
I run the preupgrade software from F9 to F10.

After the reboot I obtain a window in which I have an anaconda 11.4.1.62
exception report.
I cant write the report because it was not able to write to disk.

In the text terminal I can read:

rpmdb: Program version 4.5 doesn't match environment version 0.128
error: db4 error(-30972) from dbenv->open: DB_VERSION_MISMATCH: database
environment version mismatch
error: cannot open Packages index using db3
error: cannot open Packages database in /mnt/sysimage/var/lib/rpm

I tried to rebuild the rpm db as seen in some google search removing the
__db.* and then rebuild them with rpm --rebuilddb, but all that was done
by fedora 9.

I think I should use rpm from fedora 10 to have the right db, but I
can't imagine how to pause the installer.

Another chance could be to start the installer without the __db*, but I
don't know if rpm rebuild the database before to start the upgrade
process.

Can someone point me to the right solution?
Tnx
 Ambrogio

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux