Re: F10 question with nvidia card

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Mon, 2008-12-08 at 17:46 -0500, Chris Snook wrote:
> Steven W. Orr wrote:
> > I upgraded to F10 and now I need to get my nvidia card working. I ran
> > 
> > yum install kmod-nvidia
> > 
> > which went fine except that I still don't have the gl graphics working.
> > 
> > 514 > rpm -ql kmod-nvidia
> > (contains no files)
> > 
> > 
> > Ok, that's odd. So I then naively tried
> > 
> > [[email protected] ~]# rpm -e kmod-nvidia
> > error: Failed dependencies:
> >         kmod-nvidia >= 173.14.12-5.lvn9.1 is needed by (installed) 
> > kmod-nvidia-
> >         kmod-nvidia >= 177.82-1.fc10.4 is needed by (installed) 
> > kmod-nvidia-
> > [[email protected] ~]#
> > 
> > 
> > Since this is an upgrade, shouldn't the package be installed on top of 
> > the old one?
> > 
> > Anyone know what to do next?
> > 
> > TIA
> > 
> kmod-nvidia is a metapackage, to deal with the screwy dependency issues that 
> result from having to ship an extra variant of the nvidia module every time 
> Nvidia decides to stop supporting another generation of less-than-bleeding-edge 
> hardware.  What you're seeing is normal, and your module is already installed. 
> Have fun with X configuration.
> In other words, blame Nvidia.

...Well, blame nVidia in part. We also need to blame pilot error on the
part of the OP.

Indeed kmod-nvidia is a metapackage. Yum was used to install it, and it
did its job of pulling the appropriate dependent packages and keeping
those dependencies in place when rpm (and NOT yum) was used in an
attempt to remove the metapackage. Had yum been used, kmod-nvidia would
have been removed along with all of its dependent packages. Thus, this
metapackage, regardless of how ugly folks may think it to be, is working
as designed.

As to why the accelerated nVidia drivers did not work, there could be
several causes ranging from them not having been given a chance to load
(I usually reboot - even though I don't have to - to let everything load
up in a desired order) to that the wrong nVidia drivers were installed
(old cards can't use the new drivers last time I checked).

We just don't have enough information to say based on the information

"Only two things are infinite,
the universe and human stupidity,
and I'm not sure about the former."

-- Albert Einstein

fedora-list mailing list
[email protected]
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux