Re: F8 & F9: Date & Time

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Daniel B. Thurman wrote, On 08/04/2008 03:20 PM:
Todd Denniston wrote:
Daniel B. Thurman wrote, On 08/01/2008 09:28 PM:
> Yes, ntp is running and is properly, I believe.  It snaps in
> once I get the time setting close enough.  Somehow time
> is off anywhere from 2-8 hours in the past or in the future
> after a reboot.

A) are you dual booting with windows or any other OS/distribution (even
another instance of Fedora)?
    {perhaps the other OS thinks the hardware clock is/[is not] on UTC.}

Yes, w2kPro, XP, Vista, f8, and f9
Considering what your /etc/adjtime and /etc/sysconfig/clock below look like:
1) these settings are good, when you have to work with MS.
2) I *ASSUME* that those two files are the same on *BOTH* F8 and F9 [PLEASE verify that /etc/sysconfig/clock match between fedora systems and that /etc/adjtime on both systems ends with LOCAL]. If this assumption is not true please post both sets and identify which are for F8 and which are for F9. 3) You now need to verify that w2kPro, XP and Vista ALL use the same timezone and that it matches up with [is equivalent to] "America/Los Angeles" including dealing with DST(if needed).

B) what are the contents of /etc/adjtime and /etc/sysconfig/clock?
{repeat this question for each instance of Fedora|Unix installed on the
machine.}

# cat /etc/adjtime
0.568903 1217870667 0.000000
1217870667
LOCAL

cat /etc/sysconfig/clock
# The ZONE parameter is only evaluated by system-config-date.
# The time zone of the system is defined by the contents of /etc/localtime.
ZONE="America/Los Angeles"

C) it seems strange that the /etc/rc.d/init.d/ntpd is not syncing the clock
before kicking off ntpd.
you may need to add the following line to /etc/sysconfig/ntpd
dostep=yes

D) have you tried adding '-g' to OPTIONS=... in /etc/sysconfig/ntpd ?

Ok, added the above.  I will follow up on results soon.

<SNIP>
Note: I did not have a date problem (that I was aware of) until very recently and I ran all three (w2kPro, XP, f8) w/ no problems for a "long" time. It wasn't until I added in Vista and f9 when I noticed it.
Then verify Vista is using the SAME timezone as XP and w2kpro. If it looks
like Vista is then you might want to search the net a bit and see if someone
has noticed Vista using different data for timezones than XP or w2kpro.
[Note: don't change XP or w2kpro settings for timezone, just make sure they
are the same. Change Vista if needed.]
I ran updates on all OS's so it is hard to tell where the culprit originated. I also, in addition to the time/date problem started noticing that on boot up for f9 ONLY, a forced fsck fix ensued because the time/date was "in the future" (or so f9 believes) and this continues even now, and then the sendmail/dovecot group-writable issue cropped up, stating with f9, then later with f8.
          Very strange.
Most strange.


--
Todd Denniston
Crane Division, Naval Surface Warfare Center (NSWC Crane)
Harnessing the Power of Technology for the Warfighter

--
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux