Re: F8 & F9: Date & Time

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Todd Denniston wrote:
Daniel B. Thurman wrote, On 08/01/2008 09:28 PM:
> Jeremy wrote:
>> Hello Dan,
>>
>> Do you have the ntp daemon installed? If so check your /etc/ntp.conf
>> file. Also check if the ntp daemon is running (system - administartion
>> - services).
>>
>> Jeremy
> Uh oh, top posting? ;)
>
> Yes, ntp is running and is properly, I believe.  It snaps in
> once I get the time setting close enough.  Somehow time
> is off anywhere from 2-8 hours in the past or in the future
> after a reboot.

A) are you dual booting with windows or any other OS/distribution (even
another instance of Fedora)?
    {perhaps the other OS thinks the hardware clock is/[is not] on UTC.}

Yes, w2kPro, XP, Vista, f8, and f9
B) what are the contents of /etc/adjtime and /etc/sysconfig/clock?
{repeat this question for each instance of Fedora|Unix installed on the
machine.}

# cat /etc/adjtime
0.568903 1217870667 0.000000
1217870667
LOCAL

cat /etc/sysconfig/clock
# The ZONE parameter is only evaluated by system-config-date.
# The time zone of the system is defined by the contents of /etc/localtime.
ZONE="America/Los Angeles"

C) it seems strange that the /etc/rc.d/init.d/ntpd is not syncing the clock
before kicking off ntpd.
you may need to add the following line to /etc/sysconfig/ntpd
dostep=yes

D) have you tried adding '-g' to OPTIONS=... in /etc/sysconfig/ntpd ?

Ok, added the above.  I will follow up on results soon.

E) are you using a static IP or dynamic?
    on a wired network or wireless?
  {Network manager (the default now) works well on wireless dynamic IP
networks, but from what has been said on this list, if you are on a wired
network using static IP's then it is best to `chkconfig NetworkManager off`, `chkconfig network on`. if you are on static wireless or dynamic wired, it is a tossup as to which is best to use. NM has been set to come up AFTER many
of the services that REQUIRE networking.}

1. Static IP
2. NetManager is disabled
3. network service is enabled.

I have always done it this way due to having static ip addresses.

Note: I did not have a date problem (that I was aware of) until very recently and I ran all three (w2kPro, XP, f8) w/ no problems for a "long" time. It wasn't until I added in Vista and f9 when I noticed it. I ran updates on all OS's so it is hard to tell where the culprit originated. I also, in addition to the time/date problem started noticing that on boot up for f9 ONLY, a forced fsck fix ensued because the time/date was "in the future" (or so f9 believes) and this continues even now, and then the sendmail/dovecot group-writable issue cropped up, stating with f9, then later with f8.
          Very strange.

Dan

--
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux