Re: Yum Dependency problem [Solved]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



david walcroft wrote:
Michael Schwendt wrote:
On 01/11/2007, david walcroft <[email protected]> wrote:
I'm trying to update but get this error

Total download size: 40 M
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package python-reportlab needs python(abi) = 2.4, this is not available.
Package metakit needs python(abi) = 2.4, this is not available.
Package PyRTF needs python(abi) = 2.4, this is not available.
Package python-sqlite2 needs python(abi) = 2.4, this is not available.
Package python-imaging-tk needs python(abi) = 2.4, this is not available.
Complete!

My rpm database says this

[[email protected] ~]$ sudo rpm -q python
python-2.5-12.fc7.i386

Why does yum want python-2.4 when 2.5 is installed.
If it is required where do I find it?
What does "yum repolist" print?
Which repositories do you have configured and enabled in
/etc/yum.repos.d/*.repo?
What do you get for "rpm -qa python\*"?

I found a python -2.4 and this is what happened:-

[[email protected] rpm]$ sudo rpm -Uvh python-2.4.3-18.fc6.i386.rpm
error: Failed dependencies:
       python = 2.5-12.fc7 is needed by python-devel-2.5-12.fc7.i386
       python < 2.5-12.fc7 conflicts with python-devel-2.5-12.fc7.i386
       python(abi) = 2.5 is needed by (installed) rhpl-0.208-1.i386
       python(abi) = 2.5 is needed by (installed) libuser-0.56.2-1.i386
python(abi) = 2.5 is needed by (installed) pyxf86config-0.3.33-1.fc7.i386 python(abi) = 2.5 is needed by (installed) python-devel-2.5-12.fc7.i386 python(abi) = 2.5 is needed by (installed) pygobject2-2.12.3-3.fc7.i386 python(abi) = 2.5 is needed by (installed) yum-metadata-parser-1.1.0-2.fc7.i386
       python(abi) = 2.5 is needed by (installed) PyQt-3.17.1-1.fc7.i386
python(abi) = 2.5 is needed by (installed) pycairo-1.4.0-1.fc7.i386 python(abi) = 2.5 is needed by (installed) notify-python-0.1.0-4.fc7.i386 python(abi) = 2.5 is needed by (installed) python-numeric-24.2-4.fc7.i386 python(abi) = 2.5 is needed by (installed) python-urlgrabber-2.9.9-5.fc7.noarch python(abi) = 2.5 is needed by (installed) pyorbit-2.14.2-2.fc7.i386
       python(abi) = 2.5 is needed by (installed) subversion-1.4.3-4.i386
       python(abi) = 2.5 is needed by (installed) alchemist-1.0.37-1.i386
python(abi) = 2.5 is needed by (installed) cracklib-python-2.8.9-10.i386 python(abi) = 2.5 is needed by (installed) python-imaging-1.1.6-3.fc7.i386
       python(abi) = 2.5 is needed by (installed) PyXML-0.8.4-6.i386
       python(abi) = 2.5 is needed by (installed) tkinter-2.5-12.fc7.i386
python(abi) = 2.5 is needed by (installed) planner-0.14.2-4.fc7.i386 python(abi) = 2.5 is needed by (installed) gnome-python2-2.18.1-1.fc7.i386 python(abi) = 2.5 is needed by (installed) gnome-python2-canvas-2.18.1-1.fc7.i386 python(abi) = 2.5 is needed by (installed) gnome-python2-gnomeprint-2.18.0-1.fc7.i386 python(abi) = 2.5 is needed by (installed) gnome-python2-gconf-2.18.1-1.fc7.i386 python(abi) = 2.5 is needed by (installed) gnome-python2-gnomevfs-2.18.1-1.fc7.i386 python(abi) = 2.5 is needed by (installed) gnome-python2-gtksourceview-2.18.0-1.fc7.i386 python(abi) = 2.5 is needed by (installed) gnome-python2-bonobo-2.18.1-1.fc7.i386
       python(abi) = 2.5 is needed by (installed) rhpxl-0.47-1.fc7.i386
python(abi) = 2.5 is needed by (installed) libxml2-python-2.6.29-1.fc7.i386 python(abi) = 2.5 is needed by (installed) python-ldap-2.3-1.fc7.i386 python(abi) = 2.5 is needed by (installed) dbus-python-0.81.1-1.fc7.i386
       python(abi) = 2.5 is needed by (installed) kudzu-1.2.71.1-1.i386
python(abi) = 2.5 is needed by (installed) libsemanage-2.0.3-4.fc7.i386 python(abi) = 2.5 is needed by (installed) kdebindings-3.5.7-1.fc7.1.i386 python(abi) = 2.5 is needed by (installed) pygtk2-2.10.6-1.fc7.i386 python(abi) = 2.5 is needed by (installed) pygtk2-libglade-2.10.6-1.fc7.i386 python(abi) = 2.5 is needed by (installed) authconfig-5.3.15-1.fc7.i386 python(abi) = 2.5 is needed by (installed) policycoreutils-2.0.16-11.fc7.i386 python(abi) = 2.5 is needed by (installed) gourmet-0.13.4-1.fc7.noarch python(abi) = 2.5 is needed by (installed) pirut-1.3.9-1.fc7.noarch
       python(abi) = 2.5 is needed by (installed) newt-0.52.7-1.fc7.i386
python(abi) = 2.5 is needed by (installed) gnome-menus-2.19.4-2.fc7.i386 python(abi) = 2.5 is needed by (installed) audit-libs-python-1.5.6-2.fc7.i386
       python(abi) = 2.5 is needed by (installed) sip-4.6-2.fc7.i386
python(abi) = 2.5 is needed by (installed) libselinux-python-2.0.14-9.fc7.i386 python(abi) = 2.5 is needed by (installed) system-config-printer-libs-0.7.63.4-1.fc7.i386
       python(abi) = 2.5 is needed by (installed) hplip-1.7.4a-6.fc7.i386
       python(abi) = 2.5 is needed by (installed) vte-0.16.9-1.fc7.i386
python(abi) = 2.5 is needed by (installed) yumex-2.0.2-1.fc7.noarch python(abi) = 2.5 is needed by (installed) gnome-python2-gtkhtml2-2.14.3-5.fc7.i386 python(abi) = 2.5 is needed by (installed) rpm-python-4.4.2.2-2.fc7.i386
       python(abi) = 2.5 is needed by (installed) yum-3.2.7-1.fc7.noarch
python(abi) = 2.5 is needed by (installed) libopensync-0.22-3.fc7.i386 python(abi) = 2.5 is needed by (installed) spambayes-1.0.4-5.fc7.noarch
       python-abi = 2.5 is needed by (installed) alchemist-1.0.37-1.i386
       python-sqlite is needed by (installed) yum-3.2.7-1.fc7.noarch
python = 2.5-12.fc7 is needed by (installed) python-libs-2.5-12.fc7.i386 python = 2.5-12.fc7 is needed by (installed) python-devel-2.5-12.fc7.i386 python < 2.5-12.fc7 conflicts with (installed) python-devel-2.5-12.fc7.i386 python = 2.5-12.fc7 is needed by (installed) tkinter-2.5-12.fc7.i386
[[email protected] rpm]$

It appears that two pythons cannot exist together.
What else can I try - remove the offending rpm's?

Thanks   david

I have just done another  'yum update' for the third time today and yum
download 87 updates and cleaned up my dependency problem.
I notice that If I wait a couple of days dependency problems tend to resolve
them selves.

Thanks   david


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux