Re: Label Crap!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Mikkel L. Ellertson wrote:
Andrew Parker wrote:
On 7/24/07, Karl Larsen <[email protected]> wrote:
        It was my fault because info e2label never mentioned you must
have label= but I recall that now is the case. I might try again tomorrow and
change just one and see if I can get it to work. Can I do the same for
swap as well. I guess so but I tried and it said there were a bad
superblock.

That is because the swap is not an ext2 or ext3 file system. Try the
-L option of mkswap instead.
Don't forget that labels are used by grub too.

Labels work great if you use them correctly. But you can mess things
up if you don't know what you are doing. Then again, there are lots
of ways you can mess up your computer if you blindly change
things... The CLI tools do not stop you from shooting yourself in
the foot. The man pages tell you how to use the tool. You are
expected to know what happens if you use the tool.

Mikkel

This morning I used mkswap -L swap1 /dev/sda2 and it worked. Then I changed /etc/fstab to the LABEL=swap1 and rebooted. Happy to say now the swap files work with labels. Now to get the same stuff on the other things in fstab.


--

	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux