Re: Cannot upgrade from FC6->F7. No upgrade option given in install screen. (and RAID remnant)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear Jim:

Please forgive me for not responding sooner.  I began this reply the day you sent me the message and got sidetracked.

Thank you again for your lengthy, well thought out, consistent and technically
sound response!

I apologize if my responses were not clear.   I beg you for great forgiveness.

Again, all me methods I've used and you've suggested have been taken
because I've been under the assumption that anaconda saw remnants
of past lvm or raid devices based upon the docs in the installation guide
and I believe in the release notes.

I thoroughly read the article at  I found a slew of pointers
which I can possibly use in the future and I tried to use some of the mdadm
command suggested there.   however, since there are no physical partitions associated
with the raid device /dev/md0 mdadm will not operate on that device.  Moreover
the partitions originally associated with the device have been deleted.

I've run find on my udev directories looking for "md" but nothing appeared relative
to raid devices.

I have also noticed a complete md0 tree located in /sys/block/md0 and I suspect
that anaconda might be reading that and thinking that an raid device exists.

re: the 4GB split on files.
I'm assuming that was mentioned with the intent to burn to a DVD.
I don't have a DVD burner nor a CD burner on my linux box.  My cd
burner died a while back and I'm only using a CD reader.  I only have
a CD burner on an older windows box.

Thanks for the info regarding the incremental label naming of paritions, i.e. /usr1 etc.

Re: the reference to the f7-updates.img.
it apparently found it across the net when I specified it
on the command line since anaconda prompted me for the IP address
of this local machine along with the gateway and dns which were both my local
router.  I'm assuming that since I didn't receive an error after that that
the f7-updates.img file was used but I'm only guessing.

Again please forgive me.  The fstab I included in the previous e-mail did not have label
references for partitions on drive /dev/hdc or /dev/hdd even though partition labels
do exist for all parititions.

Well, I changed the physical device references for all partitions on /dev/hdc and /dev/hdd,
neither of which have any OS software, and voila!  I rebooted with the rescue
CD and I eventually received the install / upgrade window!  Hmm.  I think
there should be some mention in anaconda as an informational message
or as an error message flagging that as a potential "non-install" issue.

The upgrade continued from there until it reached the selinux-policy-targeted rpm
at which point it appeared to have stalled.  I checked the drive light and apparently
there was disk activity and I assumed that selinux-policy-targeted was changing file
attributes or assembling policies for selinux, so I waited.  I was tempted to do
a hard reset but I resisted.   1 1/2 hours had already passed and the install was
not finished yet.  More than 2 hours later and the install finally finished.  The machine
rebooted and I received an error, in that it couldn't find my F7 install.  So I rebooted
again and explicitly selected the F7 option from the grub boot menu (there was only
one other entry, that of the FC6) and the F7 boot continued from there.  I was then
presented from pirut with over 975 upgrade packages.  So  I spent most of Sunday
wading through those.  I'm now checking through the package manager to ensure
check for other installs.  I still have to wade through my rpm list for legacy fc6 rpms
that F7 didn't remove.

Thanks very much for your help.


On 6/7/07, Jim Cornette < [email protected]> wrote:
Lou Spironello wrote:
> Dear Jim:
> Please forgive me for NOT including fstab.  I thought I had but I did
>  not.  Since I am currently not at my machine and "out of the
> building" I cannot upload my fstab, however, I can asure you that all
> devices referenced in fstab are labeled as well as any partition on
> the disk.

I think that you sent it before. I remember all of the d# entries. It
might be good to use e2label and add meaningful labels to the
mountpoints, evwn if you use d and the number. That way if there is some
change in the future affecting device naming, you will be one step safer.

> I still see remnants of raid, i.e. /dev/md0 continues to be created
> upon reboot. I was #fedora irc yesterday speaking with someone who
> seem quite knowledgeable about these issue and he suggested to comment
> out the template reference to the md device in
> /dev/makedev.d/01linux-2.6.???   /dev/md0 was recreated upon reboot
> again.

Sorry, I misunderstood you. I thought the md device was gone after
running the gauntlet of disk management utilities.

This link briefly talks about some md management and udev. I only see
topics which may clear up what raid is doing.

The next article sounds informative to familiarize one regarding raid. I
will probably read the article in depth. There has to be some clue as to
how to prevent the md0 at zero byte from lingering around the disk.

> re: the confusing in the installer.  I thought about that when I saw
> the FC6 had labeled /boot as /boot1 and /usr as /usr1 so I relabeled
> those /boot1->/boot and /usr1->/boot and nada.  Didn't fix it.

Usually that happens if you have another installation on the same
computer. I have had several /1, /boot1 entries on my multi-version
Fedora computers. As you found out, only the references to whatever it
is called matters. If I use e2label, I usually label using a variety of

> /etc/fstab
> <snip>
> LABEL=/                 /                  ext3    defaults 1 1
>LABEL=/boot             /boot               ext3    defaults 1 2
  devpts                /dev/pts        devpts gid=5,mode=620  0 0
>tmpfs                   /dev/shm     tmpfs   defaults        0 0
>LABEL=/home             /home ext3    defaults               1 2
>proc                    /proc proc    defaults               0 0
>sysfs                   /sys sysfs   defaults                0 0
>LABEL=/usr              /usr ext3    defaults                1 2
>LABEL=SWAP-hda5         swap         swap    defaults        0 0
> /dev/hdc1              /mnt/d1            ext3    defaults 0 0
>/dev/hdc2               /mnt/d2            ext3    defaults 0 0
>/dev/hdc3               /mnt/d3            ext3    defaults 0 0
>/dev/hdd1               /mnt/d4            ext3    defaults 0 0
>/dev/hdd2               /mnt/d5            ext3    defaults 0 0
>/dev/hdd3               /mnt/d6            ext3    defaults 0 0
>/dev/hdd4               /mnt/d7            ext3    defaults 0 0
> </snip>
> I just tried the f7-updates.img using: linux
> updates=http:/
> and anaconda prompted for local ip and appeared to retrieve the
> image.
> However, that apparently didn't fix the problem.  After it searched
> for previous releases I received the "Partition Type" screen with no
> screen to select the type of install, i.e. install or upgrade.

I was not sure if your problem would be fixed by the updated image.
Briefly reading the explanation on how to use the updated image it seems
you launch the DVD and choose the additional updates selection. I was
thinking that it was just a boot disk which would ask for file location.

> I'm at my wits end.  I'm attempting to move /etc /home /usr/local
> /var/www but thinking that might have to reformat but I don't know if
> I have the space to move the files.

Someone mentioned tarring up the information, splitting them into 4 GB
files awhile back or something along those lines.

> Any other ideas?  Ideas about removing that /dev/md0 device?

The installer anaconda incorporates disk druid which I believe you could
remove the raid element. I don't know if you could remove the md and not
mess up your system by the installer going on after the disk information
is saved or not. I assume the installer will go ahead and overwrite or
copy to the same locations.

Regarding ideas to gt rid of raid, I have no ideas other than just don't
do Raid in the first place. A David Gilmour song come to mind. "No Way
out" .. (In for good)

> Any help would be appreciated.
> Thanks again. Regards, Lou
> - What about you labels in fstab? would they confuse the installer?
> Are they LABEL references or device references?

The /dev/hdc# and /dev/hdd# entries could confuse the installer.

I would backup important information and then try a yum upgrade to FC7.
I did one and it worked out OK to allow what used to work to still work
after upgrade. I dd not need to reconfigure the system.

Maybe someone familiar with raid will chime in. I seem to remember
something on the test list being discussed regarding a command to issue
to get rid of raid. You might ask on the test ist or search the archive
for information.


fedora-list mailing list
[email protected]
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux