Re: KDE update - lost control centre ?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 11 Jul 2006 14:15:11 -0500
Rex Dieter <[email protected]> wrote:

> Steven P. Ulrick wrote:
> 
> > My "problem" is that I don't run Fedora's KDE.  I compile KDE from
> > KDE's Branch 3.5 SVN tree.  So when "redhat-menus" is installed, my
> > K-menu is hosed.  Uninstall it, all is well.
> > But the problem that everyone else seems to be having is, I think,
> > different than mine, because no one seems to have mentioned that
> > they compile KDE from source.  (Even though I compile KDE from
> > source, I DO NOT compile it for the same location that Fedora
> > installs it's KDE rpm's in :))
> > 
> > Steven P. Ulrick
> > 
> > P.S.: Just wondering: should I file a bug report against
> > redhat-menus?
> 
> Do what fc's packaging now does.  Move kde's
> /etc/xdg/menus/applications.menu to (something like)
> /etc/xdg.d/kde/applications.menu and set environment variable
> XDG_CONFIG_DIRS=/etc/xdg.d/kde:/etc/xdg

Hello, Rex
First of all, thank you very much for a potential workaround to my
problem.  Before I ask my questions about what you proposed, can I
assume that since you said:
> > Do what fc's packaging now does. 
that this will not be a problem for me anymore once Fedora Core 6 comes
out?

Anyway, on to my questions:
> Move kde's /etc/xdg/menus/applications.menu to (something like)
> /etc/xdg.d/kde/applications.menu and set environment variable
> XDG_CONFIG_DIRS=/etc/xdg.d/kde:/etc/xdg

Since there is no such thing as "/etc/xdg/menus/applications.menu", I
assume that I am to move
"/usr/local/kde-svn-fc5/etc/xdg/menus/applications.menu" to, let's say,
"/etc/xdg.d/kde/applications.menu"
Ok, just did that.

Then I put 
XDG_CONFIG_DIRS=/etc/xdg.d/kde:/etc/xdg
export XDG_CONFIG_DIRS

in my ~/.bash_profile

Logged out, and logged back in, and my K-menu now looks like this:
http://www.afolkey2.net/Kmenu-Screenshot-1.jpg

I actually did /sbin/telinit 1 before I logged back in and was greeted
with the K-Menu as shown above.

I therefore assume that I did not follow your instructions correctly.

I copied the Branch 3.5 applications.menu file back
to /usr/local/kde-svn-fc5/etc/xdg/menus/ and got my menu back a few
seconds later:
http://www.afolkey2.net/Kmenu-Screenshot-2.jpg

Just for fun, I installed redhat-menus from the development tree:
redhat-menus-6.7.5-3.noarch.rpm

This left my K-Menu alone :)

I then tried removing that version, and installing the FC5 version.
Now my K-Menu is just like it is supposed to be:
Kmenu-Screenshot-2.jpg

I have had this happen on rare occasions after having to reinstall
redhat-menus when I run yum update.

None the less, let me know if and how I misunderstood your
instructions.  

Oh yeah, when I run $XDG_CONFIG_DIRS from konsole, the output is like
this:
[[email protected] ~]$
$XDG_CONFIG_DIRS bash: /etc/xdg.d/kde:/etc/xdg: No such file or
directory

Anyway, thanks for your help so far, and thanks in advance for however
you end up helping me with this.

Steven P. Ulrick

-- 
 16:22:39 up 8 days, 20:20,  4 users,  load average: 0.44, 0.82, 0.70


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux