Re: Why does not a WiFi card work in Fedora, when it works in Debian.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Tomas Larsson wrote:
-----Original Message-----
From: [email protected] [mailto:[email protected]] On Behalf Of Todd Zullinger
Sent: Wednesday, June 07, 2006 6:30 AM
To: [email protected]
Subject: Re: Why does not a WiFi card work in Fedora,when it works in Debian.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Tomas Larsson wrote:
Been struggling to get a rt61 card to work in FC4.
So-far with no
success, not with the various rt61 drivers, nor ndiswrapper. But the rt61 chipset is reported to work in debian, why not in Fedora?
It may be that the module worked in an older Fedora kernel, but as Fedora keeps moving to keep up with the upstream kernel, sometimes things outside the kernel break. If Debian ran the same version kernel, it'd likely have the same problem.
(Not just Debian either, the same applies to just about

any distro).
		Dave

Ok, question is the, should I drop FC and go for another
distro (said
to be working) or should I get another card with hopefully another chipset and start all over again?
That's a fairly subjective question. Is wireless the only thing you are about? Have you tried some other distros to see if they have other things that don't work but which work in Fedora? I doubt any distribution is perfect for anyone, except a distribution you build for yourself.
I have a system I built for a friend which includes a Linksys
WMP54G card (using an RaLink RT2500 chipset). This isn't
supported by the stock Fedora kernels, nor by the vanilla
kernel, but it works out of the box using Ubuntu. I could
have just gone with Ubuntu on the system but then I'd have
had to deal with other things that either didn't work or
worked differently than how I was used to. So my choice was
to stick with Fedora on this system but to build the rt2500
driver (I setup a system init script to rebuild the driver on
each reboot if it isn't available, so on any reboot with a
new kernel it will hopefully get built and installed
automatically at the cost of about 30 seconds added to the
bootup of a new kernel).
The advantage is that I have a system which I know very well
but which also supports the one piece of hardware which is
installed that Fedora doesn't support out of the box. If I
went with Ubuntu, I'd still be learning about the subtle
differences between it and Fedora and I'd have to keep up on
them anytime my friend had a question.
Your choice might be different.  Only you can answer that effectively.
I do agree with you, I "really" don't want to change distro, since I'm
getting familiar with Fedora, but,
I need that b..dy card up and running.
It seemms to me that quite a few cards are using RT61 now. So getting a new
card might turn out with the same problems.

The biggest problem, I think, is that I don't know wether it is the driver,
wext or wpa_suplicant that causes the problem.

With ndis and windows-driver I cant set ssid nor anything else,
wpa_supplicant nor wext don't seem to
Do anything.
With the rt2x00 driver wpa_supplicant seems not to be able to set the PSK,
hence I can't accossiate.

The original driver at RaLinkl site crashes the kernel so hard so I have to
pull the batteries and the plug,
in order to restart.

Tried to ask questions on both wpa_supplicant and ndis mailing lists, but
there is no response.

Any suggestions

If you're willing to get a new wireless card, ipw2100/2200/2915 and atheros chipsets seem to have the best driver support (from livna, atrpms, sourceforge itself, etc); ipw chipsets are mostly in centrino-based laptops so I don't know if you can purchase it separately, but if you google you can find a list of cards with an atheros chipset.
-Dan


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux