Re: I give up on x86-64, its too busted.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, 16 Apr 2006, Gene Heskett wrote:

On Sunday 16 April 2006 14:52, Gene Heskett wrote:
On Sunday 16 April 2006 13:47, Matthew Saltzman wrote:
On Sun, 16 Apr 2006, Gene Heskett wrote:
Humm, I now have installed the 386 version of FC5, but I told it to
put grub in the 1st sector of /dev/hda2, the partition named /boot.

But there's no choice of booting anything but XP.  I guess this
means I have to install it in the mbr of /dev/hda?

In which case how do I install it, and whats the magic spell to put
into grub.conf so I have a choice of what to boot?

Running the rescue cd, and cd'd to /mnt/sysimage, with a shell, a
"usr/local/sbin/grub-install /dev/hda"  gets me a message that it
can't find grub in sbin.  Of course its not there, if booted
normally it would be in /usr/sbin.
Actually, it would be in /sbin/. So it would be in /mnt/sysimage/sbin/ if
it's not part of the rescue image. Or instead of cd, use "chroot
/mnt/sysimage". That will make your environment look just like your
normal system.
Obviously there's something I'm doing wrong in trying to protect
the XP install, but how can I fix it and boot the just installed
i386 version of FC5?  I'd druther not have to go all the way thru
another install just to move the grub stuff into the MBR.
You are fine with GRUB in /dev/hda2.  Now boot with a rescue disk and
run 'fdisk /dev/hda'  Then enter 'a' to toggle the boot flag and
then '2' to make /dev/hda2 bootable, then 'w' to write the partition
table, then reboot.

Do *NOT* use the Windows disk manager to toggle the bootable flag!
Every time I tried that with Win2K, it would blow away my entire
partition table.

I always thought it would be nice if when you selected /boot's
partition for GRUB, the installer would make it bootable, but when I
bugzilla'd the request it was shot down.
I just did that, checked it with a p, then w rote it.  Got this
message: Warning: re-reading the partition table failed with error
16: Device or resource busy.  Then I ctl-d'd the shell and let it
reboot.  It booted to windows, I rebooted, hit esc, that screen
looked like the normal bios screen for selection, with neither hda1
nor hda2, just hda being the choices.  I rebooted to the rescue cd,
and re-ran fdisk & found that flag was off again.  I've set it again,
but when I w the changes, the above error is output.
I don't think the fdisk error is a problem, as it occurs on reading.
The BIOS selection screen won't show partitions, just devices. The boot process should find the active partition on the disk or boot the MBR if there is none.
Do I need to skip the search?  Ahh, that time no error when I wrote
it, but the * survived adjacent to /dev/hda2.  But no boot choice
either on the reboot.

So I power cycled it, and booted back to the rescue cd.  And no boot
flag for /dev/hda2 when I rerun fdisk /dev/hda after the power cycle.

Next suggestion reinstall/what?  If I reinstall, and let it put grub
in the mbr this time, whats the magic spell for grub.conf to make XP
Home edition usable again?

Thats based on if I'm to hate winderz as bad as I have over the years,
never having owned a winderz machine before, I'd at least like to get
to know my enemy.
And I just found GAG on the gparted disk, maybe this will work, or
should I figure on reinstalling and letting it put grub in the mbr this
time?
I don't know GAG, but gparted should be another way to handle toggling
boot flags.
I always configure my dual-boot machines with GRUB in the /boot partition
(which has to be a primary partition). Then I make that partition active,
as I described. It's always worked just as I described. When you boot,
you should see the GRUB spash screen.
Wait... In the BIOS, do you have a boot virus checker? If so, try
turning it off before you run fdisk.
--
		Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux