Re: I can't resolve from the command line but I can from a browser.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Paul Howarth wrote:
Andrew wrote:
This makes no sense to me. I can go to www.yahoo.com in a browser but I can't ping yahoo.com and nothing on my network blocks pings or yahoo.com. I also can't ping local hosts in my hosts list but I can ping their ip address. This is a fedora core 5 install and everything was working fine untill i ran yum update. Something else thats odd, ping does not say that it has failed or can't connect, it just hangs untill I break it. I also tried putting a nfs entry in my fstab and that wont mount either (it uses a host name instead of a ip address).
Here is my resolv.conf
------
search sondermuell
nameserver 192.168.1.1
nameserver 216.231.41.2
nameserver 66.93.87.2
------
Check the "hosts" entry in your /etc/nsswitch.conf

Paul.

I have

hosts:      files ldap dns

and I am pulling some of my hosts from ldap. And now that I try removing ldap from my hosts list it all works ok. But why is it doing that? I have another linux box using a different distro and everything works ok pulling hosts from the ldap server. Also when I do getent hosts I get a full list of all of my hosts (including the list from ldap). So why is getent working but it breaks when I try to resolve one of those hosts in ldap?
Thanks for your time.
-Andrew


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux