Re: kppp doesn't know modem initialisation strings !

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


[email protected] wrote:
On Sat, Dec 31, 2005 at 06:25:40AM +0530, Parameshwara Bhat wrote:

Hello List,

I am updated to latest (3.5) KDE from kde-redhat repository.When I run kppp,(sudo /usr/sbin/kppp),
set correct modem port and ISP account.It just can't dial.

When I checked in the configure dialogs,under 'modem commands',nothing is listed. Kppp has forgotten all the modem initialisation strings!
Now, I run it as user,again the same.No initialisation strings.I give the
chosen modem a name,save it and go to create a new modem,all the
initialisation strings are there.But I cannot run it as I have no access
right to modem as a user.
Stop me if you know this. There are 2 kppp files on the machine.
/usr/sbin/kppp is the actual program. /usr/bin/kppp is really a link
to consolehelper and is set up for the user to run kppp.
However, I have only had success setting /usr/sbin/kppp to SUID and
running it as a normal user.
The symlink to consolehelper is Red Hat's way to wrap stuff that
ordinarily requires root privilege (such shutdown and halt) and control
their use with PAM.
This allows, for example, you to halt the system with the halt command
if you're logged in from a virtual console, but not if you've connected
using ssh. If PAM says you can do it, consolehelper execs the same-named
program fron /sbin (and maybe from other sbin directories, I don't recall).
I think this is documented in the consolehelper package; if not, browse
the EL docs on Red Hat's website.



-- spambait
[email protected]  [email protected]
Tourist pics

do not reply off-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux