Re: Grub issues

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Thu, 2004-11-18 at 05:15 -0700, Jesse Hannah wrote:
> I have kind of a unique situation right now, and am hoping someone
> here can help. On my computer I have (had) a dual-boot system, with
> two hard drives and the Grub bootloader: one drive has Windows XP, the
> other had FC2. Yesterday I tried to upgrade to FC3, but whenever I'd
> try to do so I'd get an error saying that it couldn't transfer the
> install image to the hard drive. This was after it'd formatted that
> drive, so I tried to go back and reinstall FC2, but got the same
> error.
> Here's where my problem starts. I tried to reboot and go into XP to
> re-format that drive to FAT or something to try to fix the problem,
> but the Grub GUI was gone, and I got the command line interface. I
> thought this might be because of the other drive, so I removed it
> (leaving my XP drive in) and tried again, but this time I got a Grub
> drive error. What I think that's from is that on my main (XP) drive,
> there's something that calls Grub from what was the second (FC) drive,
> but that drive isn't there.
> So now I'm stuck: I can't reinstall FC until I fix the drive I was
> using or get a new one, and I can't boot into Windows (where all my
> stuff is) until I do that. Does anyone know how I can fix this, either
> via the Grub command line or by modifying something from a Live CD (I
> have Slax 4.2.0 and Knoppix 3.6)?
> -- 
> Jesse (JB) Hannah

If you can get to a grub commandline again

grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83

hd0 is your first ATA disk, hd1 the second and so on
0 is the first partition, 1 the second etc.
You might have to fiddle with the drive and partition selections

Once you find your XP partition
chainloader +1

I don't recall whether you need to say

You can also use the help command, there's find to find files (helps
verify you're looking at the right disk).
grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83

grub> find /config-2.6.8-1.528.2.10

grub> help cat
cat: cat FILE
    Print the contents of the file FILE.


If you can't get a grub promp0t, boot your install CD in rescue mode or
use a FC rescue disk.

At worst I'll email you a grub floppy you can write to a real floppy
with rawrite (which should be on your CD).

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux