On 11/6/06, Andrew Morton <[email protected]> wrote:
On Fri, 03 Nov 2006 18:33:31 +0200
"Burman Yan" <[email protected]> wrote:
> +
> +static unsigned int mouse = 0;
The `= 0' is unneeded.
> +module_param(mouse, bool, S_IRUGO);
> +MODULE_PARM_DESC(mouse, "Enable the input class device on module load");
Does the parameter have to be called "mouse"? I'd rename it to "input"
and drop the work "class" from parameter description.
> +
> + if (input_register_device(mdps.idev)) {
> + input_free_device(mdps.idev);
> + mdps.idev = NULL;
> + return;
> + }
> +
> + mdps.kthread = kthread_run(mdps_mouse_kthread, NULL, "kmdps");
> + if (IS_ERR(mdps.kthread)) {
> + input_unregister_device(mdps.idev);
> + mdps.idev = NULL;
> + return;
> + }
> +
Please consider implementing mdps_input_open() and mdps_input_close()
and create and run the polling thread from there - there is no point
in polling the device if noone listens to its events.
--
Dmitry
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]