>> +#define lock_super(x) do { \ >> + struct super_block *sb = x; \ >> + get_fs_excl(); \ >> + mutex_lock(&sb->s_lock); \ >> +} while(0) > >Don't do this. The "x" passed in may be "sb", and then you end up with >bogus code. So how about: static inline void lock_super(struct super_block *sb) { get_fs_excl(); mutex_lock(&sb->s_lock); return; } which avoids any naming issue. -`J' -- - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- Re: dealing with excessive includes
- From: Matthew Wilcox <[email protected]>
- Re: dealing with excessive includes
- References:
- [RFC] typechecking for get_unaligned/put_unaligned
- From: Al Viro <[email protected]>
- Re: [RFC] typechecking for get_unaligned/put_unaligned
- From: Linus Torvalds <[email protected]>
- Re: [RFC] typechecking for get_unaligned/put_unaligned
- From: Al Viro <[email protected]>
- Re: [RFC] typechecking for get_unaligned/put_unaligned
- From: Linus Torvalds <[email protected]>
- dealing with excessive includes
- From: Al Viro <[email protected]>
- Re: dealing with excessive includes
- From: Alexey Dobriyan <[email protected]>
- Re: dealing with excessive includes
- From: Al Viro <[email protected]>
- Re: dealing with excessive includes
- From: Linus Torvalds <[email protected]>
- [RFC] typechecking for get_unaligned/put_unaligned
- Prev by Date: Re: [PATCH] i386 Time: Avoid PIT SMP lockups
- Next by Date: Re: [PATCH] Block on access to temporarily unavailable pci device
- Previous by thread: Re: dealing with excessive includes
- Next by thread: Re: dealing with excessive includes
- Index(es):