On Sun, 2006-03-05 at 08:37 +1100, Peter Williams wrote:
> Mike Galbraith wrote:
> > On Sat, 2006-03-04 at 10:58 +1100, Peter Williams wrote:
> >
> >
> >>If you're going to manage the time slice in nanoseconds why not do it
> >>properly? I presume you've held back a bit in case you break something?
> >>
> >
> >
> > Do you mean the < NS_TICK thing? The spare change doesn't go away.
>
> Not exactly. I mean "Why calculate time slice in jiffies and convert to
> nanoseconds? Why not just do the calculation in nanoseconds?"
Turns out that my first instinct was right, and there is a good reason
not to. It doesn't improve readability nor do anything functional, it
only adds clutter. I much prefer the look of plain old ticks, and
having nanoseconds only intrude where they're required. I did change
NS_TICK to the less obfuscated (1000000000 / HZ), with task_timeslice()
returning a more readable ticks * NS_TICK conversion.
-Mike
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]