On Thu, 2005-12-15 at 11:21 -0800, Andrew Morton wrote: > Linus Torvalds <torvalds@osdl.org> wrote: > > > > On Thu, 15 Dec 2005, David Howells wrote: > > > > > > FROM TO > > > ============================== ========================= > > > DECLARE_MUTEX DECLARE_SEM_MUTEX > > > DECLARE_MUTEX_LOCKED DECLARE_SEM_MUTEX_LOCKED > > > Proper counting semaphore DECLARE_SEM > > > > That sounds fine. > > They should be renamed to DEFINE_* while we're there. A "declaration" is > "this thing is defined somewhere else". A "definition" is "this thing is > defined here". Why have the "MUTEX" part in there? Shouldn't that just be DECLARE_SEM (oops, I mean DEFINE_SEM). Especially that MUTEX_LOCKED! What is that? How does a MUTEX start off as locked. It can't, since a mutex must always have an owner (which, by the way, helped us in the -rt patch to find our "compat_semaphores"). So who's the owner of a DEFINE_SEM_MUTEX_LOCKED? -- Steve - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Geert Uytterhoeven <geert@linux-m68k.org>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- References:
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Paul Jackson <pj@sgi.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Alan Cox <alan@lxorguk.ukuu.org.uk>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: David Howells <dhowells@redhat.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Paul Jackson <pj@sgi.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Paul Jackson <pj@sgi.com>
- [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: David Howells <dhowells@redhat.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Andrew Morton <akpm@osdl.org>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Ingo Molnar <mingo@elte.hu>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Christoph Hellwig <hch@infradead.org>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Ingo Molnar <mingo@elte.hu>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Ingo Molnar <mingo@elte.hu>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: David Howells <dhowells@redhat.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: David Howells <dhowells@redhat.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: David Howells <dhowells@redhat.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Thomas Gleixner <tglx@linutronix.de>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Mark Lord <lkml@rtr.ca>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Andrew Morton <akpm@osdl.org>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Nikita Danilov <nikita@clusterfs.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Alan Cox <alan@lxorguk.ukuu.org.uk>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: David Howells <dhowells@redhat.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: David Howells <dhowells@redhat.com>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Linus Torvalds <torvalds@osdl.org>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- From: Andrew Morton <akpm@osdl.org>
- Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- Prev by Date: agpgart.ko can't be unloaded
- Next by Date: Re: Linux 2.6.13.5
- Previous by thread: Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- Next by thread: Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation
- Index(es):
![]() |