Re: various errors related to configuration

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Fri, 2010-12-17 at 10:17 -0600, Hugh Brown wrote:
> Les wrote:
> > I started with an evolution configuration error, and now a
> > Firefox/Mozilla configuration error, so it appears to me that this might
> > be a system level error.  Maybe some file or directory permissions
> > issue, or perhaps a generic configuration error.
> > 
> > I tried using the Firefox ProfileManager to create a new profile, but
> > that lost me all my bookmarks, as well as not changing a problem getting
> > my home page to load at startup, in spite of that being the selection on
> > the preferences page, even after creating a new user profile with the
> > profile manager.  Java won't run, even after reloading from the software
> > add/remove manager.
> Creating a new profile in Firefox does exactly that.  The old bookmarks 
> are in your old profile.  You can restore them from the old profiles 
> bookmark directory. From within the bookmark manager, choose to Import 
> and Backup->Restore->Choose file and then browse to 
> ~/.mozilla/firefox/<random string>.default/ and then pick the most 
> recent file.
> When you say Java won't run, do you mean the java plugin won't load in 
> your browser or that you can't get the command line tools to work?
> If it's the plugin that won't run, you'll need to add a link for the 
> plugin into either your user plugin directory 
> (~/.mozilla/firefox/plugins) or a system plugin directory 
> (/usr/lib64/mozilla/plugins).
> e.g. ln -s /usr/java/default/jre/lib/amd64/ 
> /usr/lib64/mozilla/plugins   to do it system wide
> > 
> >  Next I went to the Java website to get the new package, and retrieved
> > the jre-6u23-linux-x64-rpm.bin file.  when I attempted to source that
> > file I get:
> > 
> > $ ./j*bin
> > Unpacking...
> > Checksumming...
> > Extracting...
> > UnZipSFX 5.50 of 17 February 2002, by Info-ZIP ([email protected]).
> > replace jre-6u23-linux-amd64.rpm? [y]es, [n]o, [A]ll, [N]one, [r]ename:
> > y
> >   inflating: jre-6u23-linux-amd64.rpm  
> > error: can't create transaction lock on /var/lib/rpm/.rpm.lock
> > (Permission denied)
> > 
> > but the file appears to uncompress and be present as:
> > 
> > jre-6u23-linux-x64-rpm
> > 
> > but I am unsure of loading it with the prior error in existence.
> By default the script from sun/oracle tries to unpack the rpm and then 
> install it.  You ran this as a non-root user (which is fine), it tried 
> to install the rpm and failed.  You can safely install the rpm.
> Hugh
Thanks, Hugh, I had already discovered my error of not using su. DUMB,
but I have been hitting every configuration error possible, so I guess
it was absolutely required that I did this wrong as well.

I did put the link in the wrong place... DUHH!!!  I am batting 1000 on
this load of Fedora.  I have not gotten a single step right.  I guess
that cold put me farther off my game than I thought.

I appreciate the help, patience and aid from all of you.

Les H

users mailing list
[email protected]
To unsubscribe or change subscription options:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux