Re: Another preupgrade disaster -

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, 21 Nov 2009 09:48:55 -0500
Bob Goodwin <[email protected]> wrote:
> 
> However when I run fdisk on that computer it shows two drives flagged
> as boot. It boots from /dev/sdb. And I see there is an error in the 
> partitioning on /dev/sda. I wonder if that can cause confusion? It 
> certainly hasn't bothered F-11, I never noticed before. I would have 
> tried removing the other boot "*" but I'm not sure if telling it to 
> write that will cause other problems, with it all being lvm I don't
> know if anything is written to that disk that I need? I have a strong 
> temptation to run fdisk and fix that! Any suggestions ...

I don't think this matters.  I have the same, with multiple disks, and
F12 boots just fine.

> 
>     cat fdisk.txt
> 
>     #    fdisk.txt
> 
>         Device Boot      Start         End      Blocks   Id  System
>     /dev/sda1   *           1          26      204800   83  Linux
>     Partition 1 does not end on cylinder boundary.
>     /dev/sda2              26       30401   243991201   8e  Linux LVM
> 
> 
>         Device Boot      Start         End      Blocks   Id  System
>     /dev/sdb1   *           1          13      104391   83  Linux
>     /dev/sdb2              14        9729    78043770   8e  Linux LVM
> 
> Also I never removed the parts of grub.conf that refer to the kernels
> I removed before starting this exercise.

I don't think this matters either.  Grub won't look at anything until
it is selected.  It is a little sloppy, you probably should have use
rpm or yum to remove them so that all the related information was
removed as well.

At this point, if I was in your shoes, I would use the yum upgrade
method.  It requires a more in depth knowledge of dependencies and a
willingness to work around them, but it gives errors to work with when
it fails.  For that reason I would turn up error reporting
in /etc/yum.conf and redirect output to a file when running yum.   I
find preupgrade difficult to troubleshoot as compared to yum, more
blackbox, it either works or it doesn't.

http://fedoraproject.org/w/index.php?title=Upgrading_Fedora_using_yum&oldid=137395

I recommend you do this from runlevel 3 to avoid issues with X, if you
decide to go this way. After you install the fedora12-arch package,
there should be everything and update repositories in /var/cache/yum for
f12.  You can just move the preupgrade packages into one of them there
and they should be used (use the packages directory)

I haven't got anything more to offer for preupgrade help.  Maybe
someone eles can give you more help, or you can find a bugzilla that
has your error at http://bugzilla.redhat.com .  Good luck.

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux