Re: F11 and CD Failure

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, 2009-10-06 at 14:29 -0700, Daniel B. Thurman wrote:
> Aaron Konstam wrote:
> >>>   
> >>>       
> >> I tried this on F9, it does not seem to work:
> >>
> >> # mount -t iso9660 -o ro /dev/sr0 /media/cd
> >> mount: wrong fs type, bad option, bad superblock on /dev/sr0,
> >>        missing codepage or helper program, or other error
> >>        In some cases useful info is found in syslog - try
> >>        dmesg | tail  or so
> >>     
> > Yoour type was wrong. Are audio CDs for example iso99660?
> >   
> The man pages says only:  iso9660 is available, so I used this one.
> In any case, I tried it to see what it does:
> # mount -t iso99660 -o ro /dev/cdrom /media/cd
> mount: unknown filesystem type 'iso99660'
> mount: maybe you meant 'iso9660'?
yes, iso9660 - Aaron is somewhat typo prone, but recognize that an
'audio cd' does not have an iso9660 file has no file system
at all and thus cannot be mounted on any level other than 'virtual' -
i.e. so the disc can be ripped or played.
> >> Interestingly,  removing the CD from the drive results:
> >> # mount -t iso9660 -o ro /dev/sr0 /media/cd
> >> mount: No medium found
> >>     
> > Is yoour CD drive /dev/sro or /dev/sr1?
> >   
> See below...  there are TWO CD/DVD devices!
> >> Note: /dev/cdrom does not work.  I tried this for both
> >> of my CD CD/DVD drives and I note that the devices
> >> respectively are: /dev/sr0 and /dev/sr1
> >>
> >> # mount -t iso9660 -o ro /dev/cdrom /media/cd
> >> mount: special device /dev/cdrom does not exist
> >>     
> > You have no /dev/cdrom it looks like.
> Yes, no /dev/cdrom and since I have a CD device and a
> CD/DVD device, this is what I see:
> lrwxrwxrwx 1 root root 3 2009-10-06 06:49 /dev/cdrom2 -> sr0
> lrwxrwxrwx 1 root root 3 2009-10-06 06:49 /dev/cdrom6 -> sr1
> Is the reason I have no /dev/cdrom because there is no possible
> way to determine which device will have /dev/cdrom?
that could have been the issue though you certainly could recreate the
link if you wanted, but you would have to decide which drive.


ln -s /dev/sr0 /dev/cdrom
ln -s /dev/sr1 /dev/cdrom

but you cannot do both


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

fedora-list mailing list
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux