RE: ibus still broken

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


> From Ed Greshko:
> Stuart McGraw wrote:
> > I asked here a few days ago about ibus 
> > which broke after I did a yum update.
> >
> > No one responded but I saw some other posts 
> > about different problems with ibus so I 
> > waited until some new updates appeared.
> >
> > However after upgrading again just now, it 
> > is still broken -- still no input editor 
> > appears when I type the enable sequence.  
> > However now the (new) ibus icon says "no 
> > input window" when left-clicked.
> >
> > Is ibus ever going to work?  I write non-
> > english emails everyday and Fedora is 
> > useless to me without a working ibus.  
> > At this point I wonder if I should blow 
> > off Fedora and and just return to Windows?
> >
> >   
> Working just fine here....
> ibus-table-erbi-
> ibus-m17n-
> ibus-anthy-
> ibus-table-cangjie-
> ibus-devel-
> ibus-table-yong-
> ibus-hangul-
> ibus-devel-docs-
> ibus-table-wubi-
> ibus-gtk-
> ibus-chewing-
> ibus-table-
> ibus-sayura-
> ibus-table-additional-
> ibus-rawcode-
> ibus-pinyin-
> ibus-table-array30-
> ibus-libs-
> ibus-

Thanks (to you and also Craig White and Tait Clarridge)
for confirming that the problem is likely specific to 
my machine.  Those match the versions I have:


> However....  I did "notice" the problem you reported.  I didn't do too
> much investigation.  But, may have a solution.
> It seemed to me that the problem existed on a "saved session".  I'm
> running KDE and when I logged out/in it brings up the 
> previous windows,
> including a terminal session.  What I did, without really 
> thinking, was
> to close all open windows, logout and then login.  When I did 
> this, all
> was well.

I'm using Gnome but tried that and also tried a full reboot 
after the updates but that didn't help.  I also "rpm -e" all
the packages I listed and reinstalled them.

Last night I updated everything I could see that seemed related 
to gnome, gtk, pygtk, Xorg, etc., on the theory that there was 
perhaps some unrecognized dependency on a recent package but 
it didn't help.  (Unfortunately I can't keep everything up to 
date over a 3KB/s modem connection that rarely runs unattended 
for more than a couple hours.)

The only other thing I notice is when I run ibus-daemon from 
a shell with "-v", I see lots of errors like the following that 
appear when it's started:

(ibus-daemon:21356): IBUS-DEBUG: From ::1.1 to :1.3, Error: org.freedesktop.DBus.Error.Failed : 
  Can not get value [engine/anthy/shortcut/default->on_off]
(ibus-daemon:21356): IBUS-DEBUG: From ::1.1 to :1.3, Error: org.freedesktop.DBus.Error.Failed : 
  Can not get value [engine/anthy/shortcut/default->circle_input_mode]
(ibus-daemon:21356): IBUS-DEBUG: From ::1.1 to :1.3, Error: org.freedesktop.DBus.Error.Failed : 
  Can not get value [engine/anthy/shortcut/wnn->add_word]
(ibus-daemon:21356): IBUS-DEBUG: From ::1.1 to :1.3, Error: org.freedesktop.DBus.Error.Failed : 
  Can not get value [engine/anthy/shortcut/wnn->start_setup]

They all have in common a message about not getting a value 
from engine/anthy/shortcut/<something>.  Perhaps these are 
normal?  If not, do they ring a bell with anyone?
I don't see any messages when I type the activate sequence 
(alt-grave) in some window.  

> FWIW, I saw your earlier query....but since all was working 
> for me and I
> was unable to update to your level I just didn't answer.
> IMHO, people shouldn't threaten to revert to Windows.  It 
> just sounds so
> hyperbolic and makes me think that the person isn't committed 
> to Linux. 
> Almost makes me not want to help them.... 

In retrospect it did sound a little pissy -- chalk it up to a
high level of frustration.  But I have to honestly say that I
have more commitment to using a system that meets my needs than 
to FOSS political correctness.

fedora-list mailing list
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux