Re: Intel 82541GI NIC comes up at 10mbps on one port

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Sam Varshavchik wrote:
> Mikkel L. Ellertson writes:
> 
>> Try using ethtoolto lock the port to 100 Mbs Full Duplex. It is
>> probably that the two do not handshake correctly to set the faster
>> speed. If I remember correctly, that was one of the things that the
>> exact protocol was not specified, so not all hardware works correctly.
> 
> I should've mentioned that I tried that too. By itself "speed 100" has
> no effect, and the link still comes up auto-negotiated at 10mbps.
> 
> If I use "speed 100 autoneg off" the '100mbps' LED indicator on the
> router does come on, but the NIC is completely dead and does not respond
> to pings. Adding an explicit "duplex half" or "duplex full" to the mix
> makes no difference. I've also tried unplugging and plugging the cable
> after forcing the speed to 100. The router itself, as I mentioned, has
> no configurable knobs, just the ports and nothing else. I'm guessing
> that even after forcing the speed to 100mbps, the router wants to
> negotiate something.
> 
> Sorting through the documentation for e1000.ko, there's a module option
> to limit advertised link speeds to 100 mbps only, that is,
> auto-negotiation remains on but the card won't advertise 10 mbps speed.
> After enabling that option, the port does not come up at all.
> 
Well, there goes the simple fix.

I would not expect "configuration knobs" on the router. There should
be configuration web pages when you open the routers address in a
web browser. http://192.168.0.1 or http://192.168.1.1 is the default
address, if I remember right. It is in the router manual. But it
probably does not have anything to help you with your problem.

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux