RAID issues

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I've been successfully running RAID1 since the Fedora 7 days on this system. 
This morning I processed the new "updates" on the system (Fedora 9 x86_64),
since one of the updates was a new kernel I rebooted the machine (first
time in about a month which may be a clue to other software updates!)

At this point the system does not reboot and fails with the RAID partitions. 
Specifically I get to the point in the bootup "Waiting for driver
initialization" and then it follows with 

md: md6 stopped.
mdadm: no devices found for /dev/md6
md: md3 stopped.
mdadm: no devices found for /dev/md3
trying to resume from /dev/md3
Creating root device.
Mounting root filesystem.
EXT3-fs: unable to read superblock
mount: error mounting /dev/root on /sysroot as ext3: Invalid argument


/dev/md6 is root
/dev/md1 is /boot
/dev/md3 is swap
/dev/md2 is /var
/dev/md5 is /usr
/dev/md7 is /home

The RAID partitions are all partition type 0xfd (raid-autodetect)

If I boot the rescue CD, it will automatically identify my RAID partitions
and mount them as /mnt/sysimage.

I have tried removing my /etc/mdadm.conf to allow it to automatically find
the devices but no change.

After some searching I found two bugzillas that seem to be appropriate but
I am still unable to boot the system.  The links are:

https://bugzilla.redhat.com/show_bug.cgi?id=447818
https://bugzilla.redhat.com/show_bug.cgi?id=444237

I have tried recreating the section in /etc/rc.sysinit:'
#RAID SETUP
update_boot_stage RCraid
if [ -f /etc/mdadm.conf ]; then
/sbin/mdadm -A -s --auto=yes
fi

but again no luck.  I then tried the new mdadm package that's available in
the testing repo but that didn't help either.

My /etc/mdadm.conf file lists the raid volumes by their UUID number, which
I have verified is correct, plus it has been working for sometime including
previous reloads.


any suggestions would be appreciated.

Thanks!

Jeff

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux