Re: gcc updates

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



don fisher wrote:
For some reason the current gfortran uses 8 byte integers rather than 4 to record record lengths. This breaks all of the C code I have written for the final phases of the processing chain. Hence my desire to fix gfortran. I have also tried g95, but receive assembler errors on push and pop statements.
Perhaps you could spare a machine to test whether the gcc in 9 does actually solve your problems; if not it wouldn't seem to be worth it all. Or configure a virtual machine.
My environment is rather complex. I seem to remember seeing a method to employ yum to upgrade from F7 to F8. I assume a similar scheme would allow me to upgrade from F8 to F9. Can you show me a pointer to this approach?
The suggested approach is now to use preupgrade [1]. This python/yum gui and cli can be installed for F7 and F8. When run, it pre-downloads only those packages that your machine needs to upgrade {potentially saving a lot of bandwidth in downloading dvd's}. It then downloads the anaconda installer, and places an entry in grub that allows selection of an upgrade fedora item.
I have tested this on a VM starting at F7, and preupgrading to F8, then
rebooting, and preupgrading to rawhide. Both worked fine. There was no
real reason to go to F8 first - I just wanted to see how it worked.
The less preferred way is at [4].

Do you think F9 is stable enough to be useful.
It would be difficult to say for your purposes, but for me:

1. I started testing F9alpha on a F-8 vmware-server host soon after release. My interest was compiling and developing rpm spec files for a program called dvbcut. This provides a GUI for trimming a MPEG2 transport stream received from a digital TV DVB card, and outputing an MPEG2 program stream. This work is quite disk and processor intensive, yet I never saw any kernel or other issues during about two months, and in trimming 100GB of mpeg data. {I haven't fired up that vm for some weeks now}.
2. On a Dell Poweredge 2600 server {old now}, but still quite powerful
{two CPU's lsi raid etc}, I installed the 9beta. This has also run
flawlessly in terms of general reliability. I only reboot about once or
two a fortnight once a new kernel has been made available.
3. on a HP compaq nx6320 notebook. About 3 weeks ago I upgraded f8 to
9beta. In the evenings I boot, update and run the lastest packages from
rawhide. But by day, I need to operate on msXP mode on a vmare-virtual
machine {which does not yet work with f9's 2.6.25 kernels}, so I boot an
F8 kernel, so that I can use my work XP install.
The only notable hassle I saw, and this was probably present in F8,7 etc
was that I run the virtual machine in full screen mode, and hence the
power notifications aren't seen - leading to sudden shutdowns when I've
forgotten to plug the mains power in.
The laptop provides digital TV playback via it's svideo output, and
while streaming the mpeg2 video from another PC using FUSE curlftpfs. So
network is fine as well. In the past week I used mplayer to load a
playlist of remote clips including a couple of DVD movies, and let it
play all night. This went OK, until a bug in mplayer {repeatable at the
same frame of a specific clip is played} showed itself. Without that
clip, the playlist ran all night.
Again, from the list, it sounded like it was in preliminary testing.
That is correct. 9 has now been through alpha, beta and now preview releases, while further bugz are filed and fedora engineering works on Release Candidates over the next couple of weeks. There will most likely be only a few key fixes allowed into the F9 release from this point [3].
[1] http://koji.fedoraproject.org/koji/packageinfo?packageID=6045
[2] http://fedoraproject.org/wiki/Features/PreUpgrade
[3] http://fedoraproject.org/wiki/DocsProject/Schedule/9
[4] http://fedoraproject.org/wiki/YumUpgradeFaq

--
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux