Re: Samba won't dance [Solved - sort of]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, 2008-04-19 at 09:44 -0400, Claude Jones wrote:
> On Fri April 18 2008, Craig White wrote:
> > as for ports...
> > netbios-ns      137/tcp                         # NETBIOS Name Service
> > netbios-dgm     138/tcp                         # NETBIOS Datagram
> > Service
> >
> > I saw neither these descriptions (tcp or udp) nor their 137/138 numbers
> > appear in your iptables dump that you sent to the mail list. My
> > deduction that these ports were not included in your firewall listing
> > was simply noting the lack of presence of those ports in your listing.
> >
> > I believe that port 138 is only UDP traffic...don't know if TCP or UDP
> > on port 137. I enable both TCP & UDP for smb traffic.
> 
> Since the subject still works for the following, even though it digresses from 
> where this odyssey has gone up to now, I'll note the current state:
> 
> With the corrections to my misconfigured network settings, including changing 
> the personal firewall settings on the machine that was being elected master 
> browser, to trust the local zone, and, fixing the hosts file on my Fedora PC, 
> matters have greatly improved.
> 
> The Fedora box now consistently sees most machines on the network - it's 
> strange; I say most, because there's one it's not seeing now, that it was 
> seeing previously - that is, it doesn't appear in any of the lists of my 
> workgroup shares; however, that machine can see the linux box, and is 
> reliably able to print to the shared printer on the Fedora box, as can all 
> the other machines on the lan
> 
> The Windows boxes can all see each other except for the one now invisible 
> machine as well, so, this obviously is not Samba, or Fedora per se. If I 
> enter the machine name in a Windows Explorer address bar, I can browse to the 
> invisible machine, but, I can't seem to do that from the Fedora machine - 
> but, that same invisible machine can see the Fedora machine, and print to its 
> printer as already stated. 
> 
> Of the Windows boxes the Fedora machine can see, it can mount the shares on 
> one; the Windows boxes see each others' shares and readily list them, but the 
> Fedora box fails to list the shared directories except on one machine... On 
> the other machines, it just produces a 'timeout' on server message...
----
at some point, you have to figure out if this is a 'name' issue which
you can do simply by referring to the machine by it's IP address instead
of the name.

for example, I have a Windows workstation on 192.168.2.20

accessing it from a linux box...

smbclient -L 192.168.2.20
smbclient -L WIN-WORKSTATION

are equivalent...that means that my WINS is working properly. If I could
only access it via the IP address but not the name, then there is a WINS
problem.

If both of these work, then I have to see if I have an authentication
problem...

smbclient //WIN-WORKSTATION/Share_Name -U craig
should ask me for a password and if I can authenticate user craig with
the correct password, I then have access and and list/get/put various
files on the Windows share.

This easily tells me if I have an authentication issue with the Windows
system/share
----
> At several points in this conversation I've argued that Fedora's 
> implementation of Samba had issues, but at this point, my example is so 
> flawed that I'll say no more about that. I intend to try F9 from a fresh 
> install and see how that goes, once I sort out all these other network and 
> other problems. 
----
the key to solving the problem with is knowing which change you made and
why it worked and simply doing a new install isn't going to clarify
anything
----
> But, to sum up the big remaining issue: why would Fedora be able to readily 
> mount shares on one XP machine, and not another, on my network?
----
if you really want to know the answer, I have given you the tools above
to figure that out.
----
>  The only 
> difference between the two machines is that the one it can't mount is on the 
> wireless leg, while the one that works is directly plugged into the router as 
> is my Fedora machine...I have looked at the wireless settings on the router, 
> but there's not much there to configure once you allow a connection. I was 
> suspecting a mount problem, but, the fact that one of the machines does mount 
> seems to eliminate that; I am currently using the Fedora firewall, which has 
> an smb enable option and is clearly labeled as enabling traffic on 137, 138, 
> 139, and 445... Any other suggestions on what I should try? 
----
indeed...see above

it's entirely possible that there is a change from LAN segment to
wireless segment in something as inane as the MTU.

Craig

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux