Re: NetworkManager is driving me crazy

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sun, 2008-03-30 at 09:26 -0700, don vogt wrote:
> I was just about to send in a message with pretty much
> this title, so I thought I might as well jump in here.
>  I just finished installing fc8 from the livecd. I was
> using fc7, which I "yum upgraded" from fc4 to fc5 to
> fc6 to fc7 with minimal problems. I have been using
> Linux since slackware .8 (I believe. It came on 25 or
> so floppies that I downloaded over a 1200 baud modem)
> and I don't ever remember being so frustrated.
>  I have NetworkManager running at start-up and
> NetworkManager-Dispatcher also. Why? I don't know. I
> am connected through a DSL modem and eth0, and dhcp
> which I previously managed with "system config
> network" for a couple of years without problems. I
> have no wireless.
>  My initial problem was that eth0 was not activated on
> start-up, NetworkManager was starting eth0 and then
> taking it down, according to /var/log/messages.
> According to what I read about NetworkManager, it's
> first task is to keep wired connections up. I tried I
> tried to RTFM and found no useful information, I tried
> google, and found no useful information I tried the FC
> wiki, and found no useful information.
>  I tried to see the NetworkManager-info that the docs
> mentioned and found out I don't have that. Finally, by
> doing a "rpm -ql NetworkManager I found some "nm"
> scripts to get it configured. I still had problems so
> I tried to "yum remove NetworkManager and dispatcher"
> and it, for dependency, removed pidgin, which I want
> to message with my daughter. I used pidgin in fc7
> without NetworkManager very easily. So I tried "yum
> install pidgin. Lo and behold it also installed
> NetworkManager.
>  Now I have NetworkManager installed and running.
>  As a paranoid procedure, I usually disable eth0 when
> I am not using the computer for a while and then turn
> it on when I come back. Now, when I turn it on I get a
> segfault in system-config-network
>   "Determining IP information for eth0 ..
> /network-functions line 313 segnentation fault iplink
> set dev $/up> dev/null 2&1"
>  Sorry if I shouldn't have used this title. I just
> needed to vent a little (a lot?) I am not quite sure
> what to do next, remove NetworkManager (Gosh, I get
> tired of typing that) somehow without removing pidgin,
> get a new IM program? ( I hate to do that because
> configuring pidgin was problematic for me.) Set
> Network Manager to not run as a service, turn off the
> modem when I leave?
>  I am probably doing something dumb, it tends to come
> with age, but I would appreciate any suggestions.
If you have no wireless forget about NM and just run network.
"The wages of sin are death; but after they're done taking out taxes,
it's just a tired feeling:"
Aaron Konstam telephone: (210) 656-0355 e-mail: [email protected]

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux