Re: help request about NX1101 (or the IP1000) network card driver

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Phil Meyer wrote:
> Gijs wrote:
>> Gijs wrote:
>>  
>>> Hey List,
>>>
>>> I'm wondering if anyone else has any experience using the NX1101 Asus
>>> network card with kernel version 2.6.22?
>>> It identifies itself the following in lspci:
>>> Sundance Technology Inc / IC Plus Corp IC Plus IP1000 Family Gigabit
>>> Ethernet (rev 41)
>>>
>>> The reason that I'm asking is, that it took me quite some hours to get
>>> the module up and running.
>>> The makefile had some bugs in it, as well as the module source itself,
>>> which I needed to fix first.
>>> It's running now, but there seems to be something wrong with multicast.
>>> I'm using Linux-IGD for UPNP, and this requires multicast packets to
>>> work.
>>> However, when my clients send multicast packets to find the upnp
>>> daemon,
>>> the computer with the NX1101 doesn't pick them up.
>>> When I put the card into promiscuous mode, it does get the packets (and
>>> responds to them properly).
>>>
>>> I can't put my finger to it, a really weird problem.
>>>
>>>       
>> Well, guess I'll answer to my own question with another question :)
>> I finally figured out that when I ran:
>> ifconfig eth1 allmulti
>> the multicast packets did get picked up and everything works fine.
>> But how do you set your interface to allmulti at boot?
>> I've put it in my UPNP script for the moment, but I'm sure there is a
>> better place for it.
>>
>> Regards
>>
>>   
>
> My understanding is that this is a result of conscious routing decisions.
>
> By default, only the primary interface will route multicast packets. 
> It is assumed that this behavior is correct.  If it not, it is assumed
> that you know how to correct it.  It took us a while here at work to
> locate a 'proper' solution.
>
> We did it by modifying the default routing table.
>
> We modified /etc/sysconfig/static-routes
> and added:
>
> any: net 224.0.0.0 netmask 240.0.0.0 dev eth1
>
> Hope this puts you on the right trail.
>
> Good Luck!
>
Thanks for your reply, but the route itself is not the problem as far as
I know.
When I tried your approach, it didn't quite work, maybe you have a
different (or newer/older system) than mine? (FC6 here).
However after some searching around on my system I found a sysconfig
file that described all the files that sysconfig accepts inside its
directory. One of them was a file called "route-[interface]". When I
created that file, the route did get added upon ifup'ing the interface.

However, without "allmulti" it still didn't work.
Some output (the X's is my own external route/gateway to the Internet) :
[[email protected] ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
X.X.X.X      0.0.0.0         255.255.254.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
192.168.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
224.0.0.0       0.0.0.0         240.0.0.0       U     0      0        0 eth1
0.0.0.0         X.X.X.X      0.0.0.0         UG    0      0        0 eth0

[[email protected] ~]# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:18:F3:5A:A3:17
          inet addr:192.168.0.99  Bcast:192.168.255.255  Mask:255.255.0.0
          inet6 addr: fe80::218:f3ff:fe5a:a317/64 Scope:Link
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:4349446 errors:956 dropped:483 overruns:473 frame:0
          TX packets:3335322 errors:21 dropped:0 overruns:0 carrier:21
          collisions:0 txqueuelen:1000
          RX bytes:688420598 (656.5 MiB)  TX bytes:1327249829 (1.2 GiB)
          Interrupt:11 Base address:0xe800


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux