Re: wpa_supplicant.conf for F7 for WPA-PEAP

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Adam Hough <adam <at>> writes:

> Have you tried NetworkManager with with your laptop yet? I am guessing
> that you are actually missing a cert for you work's wireless network
> that you will need to get connected and authenticated to the network.

Thanks Adam - for offering some help here.

I have rather nervous about using NetworkManager due to so many having problems
with it including discussions about it not working with F8 due out soon. Also
the last time I used NM it messed with various internal settings and stopped my
manual wireless link from working when i could not get NM to work. However maybe
NM has matured somewhat in mroe recent times, and perhaps I should now try again.

Thanks for the web link - I have essentially tried the same supplicant set up as
in your example, both with and without ca_cert. I am told that the Verisign root
certs can be used (I downloaded them from Verisign, but was not sure which
certificate file was needed but tried various of the files that appeared), since
the radius server certificates here were signed by Verisign.  However I also
read that it should not be necessary to use the ca_cert parameter and it should
still be possible to connect with PWA +PEAP encryption but in that case the
server certificate is not verified by the client software. So it is more secure
to verify the server certs but I am now wondering if for some reason the
verification IS required by the Fedora version?
> Here is an write up that tells you basically what you need.  But you
> will need to get the cert that your work is using.  I would ask one of
> your colleagues for what they did as they will know more about your
> network.

The only help I have been able to get is from colleagues who say that they used
NM in Ubuntu and Debian and that it connects without any problem. I have a copy
of a supplicant setup file from the other distros where it does work, but
whataver combination of parameters in my system I draw a blank. Perhaps it is
necessary to have the ca_cert file in place and referenced correctly but the
advice I had did not yield a working system.

In fact the only example I had was to download the Verisign root files as a zip
file and unzip. The SecureServer.509 file was what I was told was needed but
that is a binary file. All the examples of PEAP setups seem to refer to .pem or
.crt files which are text files, and none are in the Verisign zip file, so I am

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux