Wireless in F7 - thank you to kernel and wireless devs

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I thought I would write a short summary of the way in which three
laptops which I am reponsible for and running F7 now have excellent
wireless support with three different drivers.

For a long time I have been struggling with getting one laptop going
on wireless using the rt2x00 driver recently supported in the kernel.
On a second machine that was running FC6 and had an ipw3945 chipset
support was solid with the ipw3945 driver and a real pain to get
working in FC6 with iwl3945.

This situation has now improved vastly.

1) Laptop 1 is a Dell d610 with iw2200 wireless. Until recently this
was set up in F7 using standard WEP wireless and avoiding the use of
wpa_supplicant or NetworkManager.
Recently I tried to set up wpa_supplicant by editing the files
/etc/wpa_supplicant/wpa_supplicant.conf and
/etc/sysconfig/wpa_supplicant appropriately.
I found to me delight that running wpa_supplicant either manually or
as a daemon worked well, and all that was necessary was to run dhcient
to get an ip address. In order to get it to run at boot it was
necessary to change the line in /etc/init.d/wpa_supplicant from
# chkconfig:   - 12 88
# chkconfig:   - 09 88

then I added two lines to /etc/rc.local
/bin/sleep 2

Now wireless comes up nicely at boot and connects seemlessly to the AP.

2) Laptop 2 is an old Amilo D6800 which has no internal wireless. I
was using the rt73 legacy driver manually compiled until recently.
This has no wpa_supplicant support. However recently the development
of the rt2x00 driver in the kernel has had a module rt73usb but has
not worked. However the new test kernel for 2.6.23 was installed and
it was found that provided /etc/modprobe.conf had a line
alias wlan0 rt73usb

and in /etc/modules.d/blacklist the module rt2500usb is blacklisted
then this modules works out of the box. Using the same technique as
for the above I can now get this wireless to come up seemlessly in

3) Laptop 3 is a Samsung Q35 machine running the ipw3945 chipset. In
the latest released kernel for F7 the iwl3945 driver comes up
seemlessly and using the same setup as in 1) wpa_supplicant also work
very consistently in this machine.

So this is the first time that all three machines run well using
wpa_supplicant and it is important to thank all the many people who
have worked hard at getting the kernel modules going, and also for the
good work on wpa_supplicant that has made this possible.

I am now looking forward to F8!


mike cohler

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux