Bizarre yum update problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



As of teh most recent updates, any attempt at runing YUM update give a ton of errors. I have tried running update via yumrex, pup, etc but all bomb out. The errors are shown below. 

Any ideas?

Thanks!

Arch

[email protected] ~]# /sbin/service yum-updatesd stop
Stopping yum-updatesd:                                     [  OK  ]
[[email protected] ~]# yum clean all
Cleaning up Everything
[[email protected] ~]# yum update -y
Setting up Update Process
fedora                    100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2         46% |===========              | 1.8 MB    00:17 ETA pprimary.sqlite.bz2        100% |=========================| 3.8 MB    00:32     
livna                     100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 142 kB    00:00     
updates                   100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================| 1.2 MB    00:03     
Resolving Dependencies
--> Running transaction check
---> Package kdebindings.i386 0:3.5.7-1.fc7.1 set to be updated
--> Processing Dependency: perl(DCOP) for package: kdesdk
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep, prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in _requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in _requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux