gimp printing again.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I cannot find or figure out how to properly configure Gimp to get a
photo to print out.  It was working once upon a time in FC6, but now it
doesn't.  I tried adding the gutenprint rpm, and that crashed the system
(I guess because I had both gutenprint and gimp-print installed).  I
uninstalled all the gimp stuff, the gutenprint and the xsane for gimp,
rebooted just to be sure, then reinstalled gimp, gimp extensions, xsane
and gutenprint.  No joy.  I get the postscript header, and a bunch of
blank pages before I cancel the print job.  And the print job is
difficult to cancel, taking minuted before the print status gui updates
and shows it canceled.

I am running FC6 fully updated, with the gimp from the add-remove
software menu.  My printer is an HP Photosmart 1215.  The printer works
from all other applications I have tried (OO, Firefox, and Evolution
among others).

The system message log only says:
Jul 14 12:28:39 school hpiod: removing usblp driver interface=0 for
hp:/usb/photosmart_1215?serial=MX1AV1Z01P0U io/hpiod/device.cpp 504 
Jul 14 12:28:39 school kernel: drivers/usb/class/usblp.c: usblp0:
removed
Jul 14 12:28:39 school photosmart_1215?serial=MX1AV1Z01P0U: INFO:
Printing... 
Jul 14 12:29:09 school hpiod: unable to write data
hp:/usb/photosmart_1215?serial=MX1AV1Z01P0U: Resource temporarily
unavailable io/hpiod/channel.cpp 63 
Jul 14 12:29:09 school photosmart_1215?serial=MX1AV1Z01P0U: ERROR: i/o
printing; will retry in 30 seconds... 

The /var/log/cups/access_log shows:
localhost - - [14/Jul/2007:12:28:39 -0700]
"POST /printers/PHOTOSMART_1215 HTTP/1.1" 200 2872662 Print-Job
successful-ok
localhost - - [14/Jul/2007:12:28:39 -0700]
"POST /printers/PHOTOSMART_1215 HTTP/1.1" 200 140 Get-Job-Attributes
successful-ok
localhost - - [14/Jul/2007:12:28:39 -0700]
"POST /printers/PHOTOSMART_1215 HTTP/1.1" 200 140 Get-Job-Attributes
successful-ok
localhost - - [14/Jul/2007:12:28:39 -0700] "POST / HTTP/1.1" 200 368
Get-Jobs successful-ok
localhost - - [14/Jul/2007:12:28:39 -0700] "POST / HTTP/1.1" 200 392
Get-Jobs successful-ok
localhost - - [14/Jul/2007:12:29:09 -0700] "POST / HTTP/1.1" 200 368
Get-Jobs successful-ok
localhost - - [14/Jul/2007:12:29:09 -0700] "POST / HTTP/1.1" 200 392
Get-Jobs successful-ok
localhost - - [14/Jul/2007:12:29:24 -0700]
"POST /printers/PHOTOSMART_1215 HTTP/1.1" 200 140 Get-Job-Attributes
successful-ok
localhost - - [14/Jul/2007:12:29:38 -0700] "POST / HTTP/1.1" 200 382
Get-Printer-Attributes successful-ok
localhost - - [14/Jul/2007:12:29:38 -0700] "POST /jobs HTTP/1.1" 200 140
Hold-Job successful-ok
localhost - - [14/Jul/2007:12:29:41 -0700] "POST / HTTP/1.1" 200 75
CUPS-Get-Default successful-ok
localhost - - [14/Jul/2007:12:29:41 -0700] "POST / HTTP/1.1" 200 75
CUPS-Get-Printers successful-ok

The /var/log/cups/error_log shows:
D [14/Jul/2007:12:28:40 -0700] cupsdProcessIPPRequest: 12 status_code=0
(successful-ok)
D [14/Jul/2007:12:28:40 -0700] cupsdAcceptClient: skipping getpeercon()
D [14/Jul/2007:12:28:40 -0700] cupsdAcceptClient: 14 from localhost
(Domain)
D [14/Jul/2007:12:28:40 -0700] cupsdCloseClient: 14
D [14/Jul/2007:12:29:09 -0700] Discarding unused printer-state-changed
event...
E [14/Jul/2007:12:29:09 -0700] [Job 119] i/o printing; will retry in 30
seconds...
D [14/Jul/2007:12:29:09 -0700] Discarding unused printer-state-changed
event...
D [14/Jul/2007:12:29:09 -0700] cupsdAcceptClient: skipping getpeercon()
D [14/Jul/2007:12:29:09 -0700] cupsdAcceptClient: 14 from localhost
(Domain)
D [14/Jul/2007:12:29:09 -0700] cupsdCloseClient: 12
D [14/Jul/2007:12:29:09 -0700] cupsdReadClient: 14 POST / HTTP/1.1
D [14/Jul/2007:12:29:09 -0700] cupsdAuthorize: No authentication data
provided.
D [14/Jul/2007:12:29:09 -0700] Get-Jobs ipp://localhost/jobs
D [14/Jul/2007:12:29:09 -0700] cupsdProcessIPPRequest: 14 status_code=0
(successful-ok)
D [14/Jul/2007:12:29:09 -0700] cupsdCloseClient: 14
D [14/Jul/2007:12:29:09 -0700] cupsdAcceptClient: skipping getpeercon()
D [14/Jul/2007:12:29:09 -0700] cupsdAcceptClient: 12 from localhost
(Domain)
D [14/Jul/2007:12:29:09 -0700] cupsdReadClient: 12 POST / HTTP/1.1
D [14/Jul/2007:12:29:09 -0700] cupsdAuthorize: No authentication data
provided.
D [14/Jul/2007:12:29:09 -0700] Get-Jobs ipp://localhost/jobs
D [14/Jul/2007:12:29:09 -0700] cupsdProcessIPPRequest: 12 status_code=0
(successful-ok)
D [14/Jul/2007:12:29:24 -0700] cupsdReadClient: 8
POST /printers/PHOTOSMART_1215 HTTP/1.1
D [14/Jul/2007:12:29:24 -0700] cupsdAuthorize: No authentication data
provided.
D [14/Jul/2007:12:29:24 -0700] Get-Job-Attributes
ipp://localhost/jobs/119
D [14/Jul/2007:12:29:24 -0700] cupsdProcessIPPRequest: 8 status_code=0
(successful-ok)
D [14/Jul/2007:12:29:38 -0700] cupsdAcceptClient: skipping getpeercon()
D [14/Jul/2007:12:29:38 -0700] cupsdAcceptClient: 14 from localhost
(Domain)
D [14/Jul/2007:12:29:38 -0700] cupsdReadClient: 14 POST / HTTP/1.1
D [14/Jul/2007:12:29:38 -0700] cupsdAuthorize: No authentication data
provided.
D [14/Jul/2007:12:29:38 -0700] Get-Printer-Attributes
ipp://localhost/printers/PHOTOSMART_1215
D [14/Jul/2007:12:29:38 -0700] cupsdProcessIPPRequest: 14 status_code=0
(successful-ok)
D [14/Jul/2007:12:29:38 -0700] cupsdReadClient: 14 POST /jobs HTTP/1.1
D [14/Jul/2007:12:29:38 -0700] cupsdAuthorize: No authentication data
provided.
D [14/Jul/2007:12:29:38 -0700] Hold-Job ipp://localhost/jobs/119
D [14/Jul/2007:12:29:38 -0700] Discarding unused printer-state-changed
event...
D [14/Jul/2007:12:29:38 -0700] Discarding unused job-state event...
D [14/Jul/2007:12:29:38 -0700] Discarding unused job-config-changed
event...
I [14/Jul/2007:12:29:38 -0700] Job 119 was held by "lesh".
D [14/Jul/2007:12:29:38 -0700] cupsdProcessIPPRequest: 14 status_code=0
(successful-ok)
D [14/Jul/2007:12:29:38 -0700] PID 5512 (/usr/lib/cups/backend/hp)
exited with no errors.
D [14/Jul/2007:12:29:41 -0700] cupsdReadClient: 14 POST / HTTP/1.1
D [14/Jul/2007:12:29:41 -0700] cupsdAuthorize: No authentication data
provided.

If I look at the plugin directories, I see no entry for gutenprint, nor
is there any entry for gutenprint in the gui for GIMP plugin management.

In the /usr/lib/gimp/2.0/plug-ins directory there is a "print" module.

And here is the contents of printrc:
]$ cat .printrc
cat: .printrc: No such file or directory
[[email protected] .gimp-2.2]$ cat printrc
#PRINTRCv1 written by GIMP-PRINT 4.2.7 - 15 Jul 2004
Current-Printer: PHOTOSMART_1215

Printer: File
Destination: 
Driver: ps2
PPD-File: 
Output-Type: 1
Resolution: 
Media-Size: 
Media-Type: 
Media-Source: 
Brightness: 1.000
Scaling: 100.000
Orientation: -1
Left: -1
Top: -1
Gamma: 1.000
Contrast: 1.000
Cyan: 1.000
Magenta: 1.000
Yellow: 1.000
Image-Type: 2
Saturation: 1.000
Density: 1.000
Ink-Type: 
Dither-Algorithm: Adaptive
Unit: 0
Custom-Page-Width: 0
Custom-Page-Height: 0

Printer: PHOTOSMART_1215
Destination: lp -s -dPHOTOSMART_1215 -oraw
Driver: ps2
PPD-File: 
Output-Type: 1
Resolution: 
Media-Size: Letter
Media-Type: 
Media-Source: 
Brightness: 1.000
Scaling: 100.000
Orientation: -1
Left: 0
Top: 18
Gamma: 1.000
Contrast: 1.000
Cyan: 1.000
Magenta: 1.000
Yellow: 1.000
Image-Type: 2
Saturation: 1.000
Density: 1.000
Ink-Type: 
Dither-Algorithm: Adaptive
Unit: 0
Custom-Page-Width: 0
Custom-Page-Height: 0

There are no ppd files in my installation according to the gimp gui for
printer setup.  The printer command window shows:
lp -s -dPHOTOSMART_1215 -oraw


So, I'm at a complete loss.  I think I have looked at every thing I
could, tried finding information in the Gimp manual, looked up numerous
references on line via google, and I cannot fathom what to do.  I guess
I'm just stupid.  Please educate this old fool.

Regards,
Les H




[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux