Re: F7- cups - evolution - remote printing failure

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, 2007-07-07 at 21:38 -0500, Gregory P. Ennis wrote:
> On Sat, 2007-07-07 at 08:08 -0500, Aaron Konstam wrote:
> > On Fri, 2007-07-06 at 21:31 -0500, Gregory P. Ennis wrote:
> > > I have two installations of F7 on laptops that replaced Fc5 and Fc6 that
> > > have gone very well except for using remote cups printers on different
> > > networks.  This function worked well on Fc5 and Fc6.
> > > 
> > > When trying to print an e-mail message all the printers are listed, but
> > > the "PRINT" tab becomes shaded for the printers outside of the local
> > > network.
> > > 
> > > This same symptom was present in OppenOffice of F7 but was remedied by
> > > checking the "Use OpenOffice dialogs" checkbox in the options.
> > > .
> > > This appears to be a bug in evolution and openoffice, but before I
> > > filled out a bug report I was hoping someone might have a fix.  
> > > 
> > > All the networked cups printers can be accessed via the command line so
> > > cups seems to be working perfectly.
> > > 
> > > Thank for your help,
> > > 
> > > Greg Ennis
> > This is totally controlled by the client.conf  and cupsd.conf files on
> > the client and the server(s). For example, not specifying a server in
> > the client.conf file on the clients will only alllow you to print to
> > printers on the same lan. the cupsd.conf on the server(s) determine to
> > what newtworks will the printer broadcaqting be done.
> > 
> > If it worked in FC5 and FC6 then your files on those systems were
> > different then your current files. You should check the manuals at
> > localhost:631.
> > -- 
> > Aaron Konstam <[email protected]>
> > 
> Aaron,
> 
> Thanks for your response.  I checked the client.conf file and cupsd.conf
> file and there were some slight differences between what I had on the
> old FC5 system and the new F7 system so I don't think the problem is
> related to this.  In fact I swapped out both files with the older files
> just to see and the same symptoms occur.  
> 
> I also have different FC6 on this same network, and cups is set up with
> very similar settings, and everything works perfectly on it.  The FC6
> evolution is 2.8.3 whereas the F7 evolution is 2.10.1.  
> 
> The printers are listed using lpstat -a on both systems, and on both
> systems when I try to print from within evolution I get the same printer
> listings, but the F7 evolution has the "Print" tab shaded when I try to
> print to a printer outside of my local network.  I can print remotely on
> F7 from the command line using lp -d lpt10 ./filename, and lpt10 is
> displayed on the F7 evolution, but the "Print" tab is shaded when I
> select lpt10 making the print function unreachable.  
> 
> Thank you for your suggestion to take a hard look at the config files,
> but they are working like cups should be working.  
> 
> If you or others have additional ideas .... please help.
> 
> Greg
> 
Well if lpstat says the printer is availble and lpr can print to the
printer, you have convinced me that is a problem with evolution. It is a
mystery though why printine works for me. However all my printers are on
the same lan.
--
=======================================================================
You can rent this space for only $5 a week.
=======================================================================
Aaron Konstam telephone: (210) 656-0355 e-mail: [email protected]


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux