Re: Centrino duo, card reader and Linux

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Friday 29 June 2007 16:46:30 Phil Meyer wrote:
> Marcelo Magno T. Sales wrote:
> > Hi,
> >
> > I have a Centrino Duo notebook which has an embedded card reader (for
> > memory sticks, SD cards, XD cards, etc.). No card inserted in the reader
> > is detected by Fedora. I was hoping that the new F7 kernel would support
> > it, but the reader is still dead after the upgrade.
> > lspci shows:
> > (...)
> > 05:03.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822
> > SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
> > 05:03.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
> > 05:03.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host
> > Adapter (rev 0a)
> > 05:03.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev
> > 05)
> That is the exact same device in my laptop and it works great.
> I have tried 1GB 2GB and 4GB regular SD cards.
> I have NOT tried 8GB SDHC cards.
> What card are you trying?
> The driver in question is: mmc, which includes mmc_core and mmc_block.
> Do the drivers load for you?
> Plug in a SD card and:
> # lsmod | grep mmc
> and
> dmesg | tail
> You should see something like this from dmesg:
> mmcblk0: mmc0:1234 SD04G 4018176KiB
>  mmcblk0: p1
> Good luck!

If the driver is loaded then you might find this a help from a previous post. 
I have copied and paste

This is determined by 
You can either edit it or just move it out of that location and auto 
mounting would work.

It has been done as a security measure but policy kit in Fedora 8 should 
make this much more usable. There is a recent discussion in fedora-devel 
list about this FYI.


Guy Fawkes, the only man to enter the house's of Parliament
with honest intentions, (he was going to blow them up!)
Registered Linux user number 414240

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux