Re: how to get dhclient to reconfigure link?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Alan Cox <alan@xxxxxxxxxxxxxxxxxxx> wrote:

On Wed, 02 May 2007 22:46:06 -0400
Joe Smith <jes@xxxxxxxxxxx> wrote:

> I had to unplug my network connection (FC5; single PC-cable modem) for a > couple of hours today, and when I plugged it back in, the kernel > recognized that the link was up again, but the dhcp client did not > reconfigure the link. I tried ifconfig eth0 down/up--no change. I > finally just killed and re-started dhclient, which worked but seems > pretty clunky. What's the recommended solution?


	ifdown eth0
	ifup eth0

(which will restart negotiation etc), waiting (which should eventually
get around to retrying), or run the GUI network config tool and take the
iface down/up.
It looks like dhclient will "stick" sometimes and not exit with an "ifdown". I just had this happen this morning. I've been working with and testing the wireless link on my laptop for about a week with lots of "ifdown eth0" (the wire) followed by "ifup eth1" (the wireless). This morning I had to kill dhclient after the "ifdown eth0" before I could successfully do an "ifup eth1". Maybe if your timing is perfectly wrong and you catch dhclient when it's getting a new lease or something it doesn't exit on an ifdown.

BTW, I finally got my wireless running stably on the laptop with ndiswrapper by going to the 2.6.21 kernel from Really odd since I configured the kernel with "make oldconfig" and didn't see anything related to some of the known pitfalls for ndiswrapper (e.g., CONFIG_4KSTACKS) but it seems to run fine both over time (several days) and with lots of traffic (amanda backup keeps getting the rebuilt kernel files object files as I tweak the configuration). This is with a x86_64 kernel.


Politics, n. Strife of interests masquerading as a contest of principles.
-- Ambrose Bierce

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux