Re: how to reformat floppies that have data on them

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tuesday 10 April 2007 22:27, Rick Stevens wrote:
> On Tue, 2007-04-10 at 22:04 +0200, Nigel Henry wrote:
> > I can use dd to put data on a new formatted floppy, but how do I reuse an
> > old floppy. I tried it on linux using dd, but got input/output errors,
> > and even tried it on that other OS, but that couln't complete the format.
> > I even tried reformatting an XP boot floppy on XP, and it couldn't
> > complete the format.
> >
> > I'm a bit lost at the moment. I'd buy some new ones, but my supplier
> > hasn't any available.
> >
> > I know floppies are legacy, but I have an old machine with my smoothwall
> > firewall on it, and it can't boot from cdrom, so I need to remake the 2
> > floppies that start off the install.

Rick writes
> For an MS-DOS floppy,
>  #fdformat /dev/fd0H1440;mformat a:

No go with that, see below.

[[email protected] djmons]# fdformat /dev/fd0H 1440;mformat a:
usage: fdformat [ -n ] device
mformat: init: set default params

Bit lost cause havn't worked with these programs before.

On to the man page for fdformat, and I think you did a typo between "fd0H" and 
"1440" , no space required. So ran it again, and it started formatting the 
disc, but then crapped out with the output below. Doh, Doh, and thrice Doh.

[[email protected] djmons]# fdformat /dev/fd0H1440;mformat a:
Double-sided, 80 tracks, 18 sec/track. Total capacity 1440 kB.
Formatting ... done
Verifying ... Read: : Input/output error
Problem reading cylinder 0, expected 18432, read -1
plain_io: Input/output error
mformat: Error reading from '/dev/fd0', wrong parameters?

Any suggestions, apart from throwing the floppies in the trash?


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux