Re: Usb/udev/kernel problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sunday 18 February 2007, Ian Astley wrote:
> On 18 Feb 2007, at 9:41, Anne Wilson wrote:
> > This box is an i686 box, but for some reason I have i586 kernels and
> > kernel-devel packages installed.  I think this may be relevant to this
> > problem.
> 'Morning, Anne. I had a similar problem: there is an error with
> Anaconda in the installation of FC6. See,
> A Google search for
> i586 i686 linux kernel anaconda bug
> will get you a number of alternatives to read with your Sunday coffee
> and croissants but they all say pretty much the same thing. I
> performed this fix on my machine and it's fine now. I trust the same
> will apply to your problem.
I knew about this, but thought that the important thing was to have the kernel 
and kernel-devel packages matching.

rpm -qa 'kernel*' --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|sort

shows a horrible mish-mash!


I could have sworn that querying uname had said that I had the i586 kernel 
installed.  OK - so now to clean up, then get the correct kernel-devel and/or 
kernel-headers package.

Thanks for the prompt.  I thought I had dealt with this problem long ago.

Later -

Now I'm really confused.  I removed the kernel-devel-2.6.19-1.2911.fc6.i586, 
but when I tried to remove the kernel-headers-2.6.19-1.2911.fc6.i386 I was 
told that 149 packages would be removed, so that's not possible.

I then tried to get kernel-devel-2.6.19-1.2911.fc6.i686, but yum search 
couldn't find it.  Running 'yum update' simply puts the .i586 package back.  
I tried the various commands from but none of them worked.

I'm stuck.


Attachment: pgpPPjhlliAtX.pgp
Description: PGP signature

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux