Re: diskless fc6

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, January 25, 2007 10:05 am, Chris Rouch wrote:
> On 1/19/07, Chris Rouch <[email protected]> wrote:
>> Does anyone have diskless booting working with fc6 and could tell me
>> what they did to get it to work?
>>
>> I have a diskless via epia M10K box, booting an fc4 image. Yesterday I
>> upgraded the server it boots from from fc4 to fc6, reran
>> system-config-netboot and successfully got it to boot as it had
>> before, i.e. an fc4 image loaded over nfs.
>>
>> I then tried to create an fc6 boot image. I installed fc6 on a third
>> machine and copied the files as described in the howto (and the
>> system-config-netboot dialog). I changed the properties of the
>> diskless box to use the fc6 image. This begins to boot, but then gets
>> a kernel panic. The messages I see are like this:
>>
>> Ramdisk: compressed image found at block 0
>> time: acpi_pm clocksource has been installed
>> EXT2-fs: blocksize too small for device
>> grow-buffers: requested out-of-range block 10446744071562067960 for
>> device ram0
>> isofs_fill_super: bread failed, dev=ram0, iso_blknum=17 block=2147483618
>> No filesystem could mount root, tried: ext2 iso9660
>> Kernel panic - not syncing: VFS: Unable  to mount root fs on
>> unknown-block(1,0)
>>
>> (the above was hand copied from a screenshot, so there may be typos)
>>
>
> Adding "ramdisk_blocksize=1024" to the kernel command line gets me
> past this speed bump, but then nfs fails to mount the image.

I've got the same problem... how did you solve the nfs mount problem ??
I suspect that the 'mount' binary in the initrd does not handle NFS
mounting somehow.... where does 'mount' come from ? is it from busybox or
from util-linux ?
regards

-- 
ICQ:290677265
SKYPE:d.rossetti





[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux