Re: Package updater broke?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



John Bowden wrote:
On Tue, 2007-01-09 at 01:44 +0000, John Bowden wrote:
On Mon, 2007-01-08 at 20:32 -0500, Jim Cornette wrote:
John Bowden wrote:
Hi List.
I have been off line for nearly two weeks due to my broad band
connection failing. As soon as I got my connection up I went to the
Software updater to check for any up dates and as expected it gave me a
long list. First I selected all the packages but kept getting error
messages complaining about unresolved dependencies. I then selected each
package one at a time and get the same unresolved dependencies message
for each package (I have tried the first 12 packages so far). I thought
the package updater was supposed to sort out the dependencies
automatically? Any ideas whats wrong?
john


You might try to open a root terminal and run yum clean all. Maybe there are old headers left over since the time you last updated that it is using as reference to packages.
After cleaning up the headers, you might as well try running yum update
from the CLI since you are already there. You will probably get more
descriptive error outputs from the output of yum if it still fails.
Jim

--
If you don't have time to do it right, where are you going to find the time
to do it over?

After posting my last email I had a quick look at "man yum" and then
tried yum update after su-ing. It did update most but failed on a lot of
others. will try your clean all command


That seems to have worked much better. Just two error messages:-

http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/extras/development/i386/wine-docs-0.9.27-1.fc7.noarch.rpm: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
Error: failure: wine-docs-0.9.27-1.fc7.noarch.rpm from
extras-development: [Errno 256] No more mirrors to try.
[[email protected] led]#
I'm guessing these are caused by these sites being down, hopefully
temporarily, so I will leave it for now and have another go later on
today when I get up. Thanks for your help
Regards John


I just noticed that you must have the extras development repository
enabled. Are you running FC6 or development? You might need to edit
/etc/yum.repos.d/fedora-extras-development.repo file and change
enabled=1 to enabled=0
Jim

--
A computer lets you make more mistakes faster than any other invention,
with the possible exceptions of handguns and Tequilla.
	-- Mitch Ratcliffe


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux