Re: export LD_ASSUME_KERNEL problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



2006/11/7, Jakub Jelinek <[email protected]>:
On Tue, Nov 07, 2006 at 05:48:47PM +0300, Artur G. Sibagatullin wrote:
> I installed FC6 and met a problem. I can't export variable
> LD_ASSUME_KERNEL. That it what I've got:
>
> $export LD_ASSUME_KERNEL=2.4.1
> date: error while loading shared libraries: librt.so.1: cannot open
> shared object file: No such file or directory
>
> How can I solve the problem? Any suggestions?

First of all, what problem are you trying to solve with this?
If you need LinuxThreads support, you are out of luck in Fedora Core 5
or newer, there is only NPTL, LinuxThreads has been deprecated for many
years.  You can set LD_ASSUME_KERNEL even in FC6, but the value
needs to be 2.6.9 or higher, but at least for the FC6 shipped libraries
it will not change anything.
You might try to run the app which you are interested in without
LD_ASSUME_KERNEL, if it works with NPTL, fine, if it doesn't, demand
a fix from whomever provided it.

        Jakub
Hi Jakub,

how could I install Oracle for example. AFAIK one must set LD_ASSUME_KERNEL to
something like 2.4.1 but not 2.6.x.
And this is not the only application. With installing Websphere MQ one
must also set this
variable lower than actual kernel version.

Wolfgang
--
Wolfgang Leideck
Alberichstr. 14
D - 68199 Mannheim


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux