Re: Rsync help needed

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Thu, 2006-09-21 at 10:11 -0700, Rick Stevens wrote:
> On Thu, 2006-09-21 at 17:57 +0100, Anne Wilson wrote:
> > On Thursday 21 September 2006 02:25, Bob Chiodini wrote:
> > >
> > > Looking at the man page for rsync the -o option which is implied by the
> > > -a option requires super-user access.  It does not say that -a requires
> > > super-user access, however. 
> "-a" implies "-o -D", both of which require root access.
> > I run an almost identical rsync from this box, as user, but it is from my own 
> > directories to my own directories on borg.  Just in case, though, I ran the 
> > rsync from a root console and got the same timestamp errors.
> > 
> > > Try using -rlptguvz. 
> > 
> > Tried that as well, but still getting the same timestamp errors.
> The "-t" option says "preserve timestamps" and if the two machines are
> out of time sync, you can certainly get errors of that nature.  If you
> don't need the timestamps, then omit the "t" from the command options
> and let the destination file have the ctime, mtime and atime set to the
> current date and time.  I'd also highly recommend you fire up ntpd and
> get the machines you deal with synchronized.


If it is not a time sync problem, are you running selinux, and are there
any errors in the log?  Does it work as root?  If so you could put the
command in root's crontab and keep the -auvz options.


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux