Re: Problem booting OS on IDE PCI adaptor card with Grub in MBR of hda

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sunday 16 July 2006 06:26, Mikkel L. Ellertson wrote:
> nigel henry wrote:
> > I'v actually just got FC1 to boot from the main bootloader in hda, but
> > that is from a kernel entry, not the chainloader. All I get from trying
> > to chainload is a grub prompt.
> >
> > Running /sbin/grub I tried different drives to see if grub> root (hdx,0)
> > would find somewhere to put FC1's bootloader. grub> root (hd2,0) printed
> > the following, after also running grub> setup (hd2).
> >
> > grub> root (hd2,0)
> >  Filesystem type is ext2fs, partition type 0x83
> >
> > grub> setup (hd2)
> >  Checking if "/boot/grub/stage1" exists... yes
> >  Checking if "/boot/grub/stage2" exists... yes
> >  Checking if "/boot/grub/e2fs_stage1_5" exists... yes
> >  Running "embed /boot/grub/e2fs_stage1_5 (hd2)"...  15 sectors are
> > embedded. succeeded
> >  Running "install /boot/grub/stage1 (hd2) (hd2)1+15 p
> > (hd2,0)/boot/grub/stage2 /boot/grub/grub.conf"... succeeded
> > Done.
> >
> > There's some weird stuff going on here, as (hd2) hdc, is the cdwriter,
> > and when I ran grub> setup (hd2) the writers light was flickering quite a
> > bit, but as you can see from the output above, the bootloader installed
> > ok.
> The CD is not a hard drive. Grub does not care about the interface,
> just about the BIOS numbering. A SCSI hard drive would also show up
> as (hdx). For that matter, my SATA hard drive is (hd0) under Grub,
> and /dev/sda under Linux.

Yes the BIOS numbering compared to the /dev entries, caused the confusion, 
resulting in the ridiculous scenario of trying to force Grub to install on 
(hd4) a truly non-existant disc.
> > Another thing that is a bit weird, is that the kernel entries in
> > grub.conf, apart from the latest from fedora legacy show a strange entry
> > after label=/. Again, as below.
> > LABEL=/ hdc=ide-scsi   (perhaps this has something to do with Win ME
> > identifying the IDE PCI adaptor card as a scsi controller)
> >
> > I've never seen that before.
> NO, it is using SCSI emulation for the CD-ROM drive, so that you can
> access it as a SCSI CD. This used to be used a lot with CD writers.
> FC1 is probably old enough that it still needs it. I don't remember
> what version of the kernel/cdrecord let you use the IDE command set
> to control a CD writer.
> > Quite what the situation is with the cdwriter now, I don't know. It
> > wasn't showing up in the mobo's BIOS before. Only the cdrom drive (hdd),
> > and the dvdrom (hdg) which I couldn't boot a distro from were there.
> >
> > As I can boot an FC1 kernel from the main bootloader, the harddrive on
> > the IDE PCI adaptor card is obviously accessable, but there is obviously
> > some problem with the BIOS regarding drive ID's. Webmin on FC1 still
> > shows the harddrive on the IDE PCI adaptor card as IDE device E, and yet
> > the mobo's BIOS is identifying this same harddrive as hdc.
> >
> > Anyway, the only problem left now is accessing the Grub menu. I've been
> > back into FC1, and changed the splashimage from (hd4,0) to (hd2,0), but
> > still only get the Grub prompt when trying to chainload to (hd2,0) hdc1,
> > aka hde1.
> >
> > Nigel.
> One thing to keep firmly in mind is that the /dev/hdx device entries
> are not the same as the BIOS hard drive or Grub numbering. As far as
> the BIOS is concerned, the first hard drive it finds is device 80,
> then second one 81, and so on. It gets interesting when you have
> both SCSI and IDE drives in the same system, because if the system
> is set to boot off the SCSI controller, then the first SCSI drive
> will be BIOS 80, Grub (hd0). Also, if you tell the BIOS to boot off
> a hard drive other then the first one, the numbering changes. I have
> not checked into it, but it would be interesting to see how the
> drives are numbered when you boot off of a USB drive.

Thankfully I only have IDE drives, no doubt more knowledge of how Grub works, 
would have saved a lot of time and hair removal.
> Mikkel

Thanks for all your friendly help.

> --
>   Do not meddle in the affairs of dragons,
> for thou art crunchy and taste good with Ketchup!

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux