Re: Console stops scrolling

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Mon, 2006-07-10 at 13:15 +0100, James Wilkinson wrote: 
> Gordon Hay wrote:
> > Booting FC5, messages populate screen, scrolling normally until the
> > following error occurs:
> >         PCI: Probing PCI hardware
> >         PCI: failed to allocate mem resource #6 at [email protected] for
> >         0000:01:06.0
> >         PCI: Bridge for 0000:00:0d.0
> >         
> > At this point the cursor is stuck at bottom left and as far as I can
> > tell is unmovable.  The screen no longer scrolls, and the console is
> > unusable.  
> > 
> > The system appears to boot OK, however: it's accessible via SSH and
> > seems fine.
> > 
> > Is there a way to "unlock" this frozen console?
> Sounds like a kernel problem, or possibly a hardware problem.
Kernel: I've tried several recent FC5 kernels, but the problem didn't
happen with FC4... 
Hardware: well, not monitor hardware, 'cause it works fine with other
systems via a KVM.  Server hardware: well, maybe, but it does seem to
run OK otherwise.  See below for config info. 
> > Also, if anyone knows what the PCI messages are actually trying to tell
> > me, I'd be grateful.... 
> Well, you could try running lspci and looking for what corresponds to
> 01:06.0 and 00:0d.0. Depending on what they are, you might be able to
> tell the kernel not to use those features.

lspci says:
00:0d.0 PCI bridge: IBM IBM27-82351 (rev 01)
01:06.0 VGA compatible controller: Cirrus Logic GD 5430/40 [Alpine] (rev
01:07.0 Network controller: Compaq Computer Corporation Netelligent
Integrated 1 0/100 TX UTP (rev 10)
01:09.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev

Does this generate any ideas? 
This machine does have an odd memory config, see below...
> Are you using proprietary kernel modules (Nvidia, ATi, VMware, etc)?
> Have you tried without them?
No, standard kernels as installed by, and updated by FC5's normal
> What sort of system is this, anyway?
It's an elderly Compaq Proliant 2500 server
- 2 x 200MHz monster Pentium Pro processors
- 288MB of RAM
- no graphics. No Gnome/KDE or X, just a text-only installation using
the the "standard" motherboard VGA controller (though that seems to be
implicated somewhere...)

The odd thing about this system is the memory "hole" between 640k and
1m, and the fact that a standard FC4/5 boot only sees 16MB of RAM.
Adding kernel parameters "mem=exactmap [email protected] [email protected]"
allows all the memory to be seen.

But I wonder if the VGA controller is trying to use memory that doesn't
exist?  Are my kernel parameters confusing things?  Though they do allow
the system to boot and use all its memory, and apparently run fine (as
long as I use SSH and not the console...) 

> Hope this helps,
> James.

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux