Re: X still not starting after latest updates using r128 driver

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Nigel Henry wrote:
Hi. I'm not having much success here. The machine is a Gateway 500 P111 Katmai, with 256MB RAM. Graphics card is an old Rage128, using the r128 driver. FC1,2,and3 on this machine have no problems with the driver. I can play DVD's ok, no judders in the video, and the sound is in sync.
With FC5, the only way I can get X to start is by changing the r128 driver
for the vesa one in /etc/X11/xorg.conf. The graphics are pretty much ok using
the vesa driver, apart from playing DVD's, when it's like going back to the
days of the silent movies.
Some sort of reply would be appreciated. /sbin/lspci for the graphics card is
below, and also the message from /var/log/Xorg.setup.log, for the last time I
tried the r128 driver after doing updates to the system.
/sbin/lspci
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 RL/VR AGP

And this is some output from /etc/sysconfig/hwconf
class: VIDEO
bus: PCI
detached: 0
driver: aty128fb
desc: "ATI Technologies Inc Rage 128 RL/VR AGP"
video.xdriver: r128
vendorId: 1002
deviceId: 524c
subVendorId: 1002
subDeviceId: 0008
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0
-
class: VIDEO
bus: DDC
detached: 0
desc: "ATI Technologies Inc. R128"
mem: 8192

Message from /var/log/Xorg.setup.log

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp i686Red Hat, Inc.
Current Operating System: Linux localhost 2.6.16-1.2080.13.rrt.rhfc5.ccrma #1 PREEMPT Sat Apr 22 19:05:27 EDT 2006 i686
Build Date: 02 May 2006
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null", Time: Sat May 27 00:12:42 2006
(++) Using config file: "/tmp/tmp5Ed8TDxorg.config"
(WW) ****INVALID IO ALLOCATION**** b: 0x9000 e: 0x90ff correcting Requesting insufficient memory window!: start: 0x9000 end: 0x90ff size 0xf0120100 Requesting insufficient memory window!: start: 0x9400 end: 0x94ff size 0xf0120100 Requesting insufficient memory window!: start: 0x9800 end: 0x98ff size 0xf0120100 Requesting insufficient memory window!: start: 0x9c00 end: 0x9cff size 0xf0120100
(EE) Cannot find a replacement memory range

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x87) [0x80b86c7]
1: [0x472420]
2: /usr/lib/xorg/modules/drivers/r128_drv.so(R128FreeScreen+0x2b) [0x13ea9b]
3: /usr/bin/Xorg(xf86DeleteScreen+0x5e) [0x80c50ee]
4: /usr/bin/Xorg(InitOutput+0x9e4) [0x80a2364]
5: /usr/bin/Xorg(main+0x276) [0x806ffc6]
6: /lib/libc.so.6(__libc_start_main+0xdc) [0x4a5724]
7: /usr/bin/Xorg(FontFileCompleteXLFD+0xb1) [0x806f511]

Fatal server error:
Caught signal 11.  Server aborting


This is an old Rage 128 graphics card, not some cutting edge high performance gamers card, that needs the latest drivers from the card manufacturers.
Help would be appreciated. Nigel.




You might get some clues using 'info r128'
I browsed the info page and it refers to your video card as supported. It lists modes and parameters also.
Excerpt:
SUPPORTED HARDWARE
The r128 driver supports all ATI Rage 128 based video cards including
the Rage Fury AGP 32MB, the XPERT 128 AGP 16MB and the XPERT 99 AGP
8MB.

CONFIGURATION DETAILS
Please refer to xorg.conf(5x) for general configuration details. This
section only covers configuration details specific to this driver.

Jim


--
Fourth Law of Applied Terror:
	The night before the English History mid-term, your Biology
	instructor will assign 200 pages on planaria.

Corollary:
	Every instructor assumes that you have nothing else to do except
	study for that instructor's course.


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux